Hesitation, Bucking, Spitting, Popping after Tranny Rebuild - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-21-2012, 08:23 PM   #1
Jeeper
 
T'sTJ's Avatar
 
Join Date: Jun 2010
Location: SoCal
Posts: 97
Images: 7
Hesitation, Bucking, Spitting, Popping after Tranny Rebuild

I just picked up my Jeep after getting the tranny rebuilt. A quarter mile down the street, from the shop, it started hesitating when I'd hit the gas.

I thought that since it was out of service and sitting in my driveway for several months, and with a battery needing jumping, that it just needed a drive to freshen her up.

I drove about 10 miles from the shop to my home. Along that way I saw the tach jump 500rpm continuously, heard pinging, kind of like timing pinging. It basically bucked, jerked and everything under the sun all the way home. It didn't overheat as I had imagined it would, just running extremely rough.

The mechanic left just after I picked it up, not back until Monday.

Could it simply be a plug gone bad?

What wires are disconnected during a tranny rebuild, that may be undone and causing this?

What else should I check?

Thanks for any help.
Tony

T'sTJ is offline   Quote Quick Reply
Old 09-21-2012, 10:23 PM   #2
Jeeper
 
T'sTJ's Avatar
 
Join Date: Jun 2010
Location: SoCal
Posts: 97
Images: 7
Update:
Trans fluid all over the driveway.

T'sTJ is offline   Quote Quick Reply
Old 09-21-2012, 11:11 PM   #3
Jeeper
 
Leeroy Jeepkins's Avatar
 
Join Date: Nov 2010
Location: Bucks County,PA
Posts: 488
Probably just needs some new wiper blades or something
Leeroy Jeepkins is offline   Quote Quick Reply
Old 09-22-2012, 10:03 AM   #4
Jeeper
 
Evpjr's Avatar
 
Join Date: May 2012
Location: Bakersfield
Posts: 365
Images: 1
I'm guessing you have an automatic, so will suggest you check the CPS (crankshaft position sensor). May be a loose connection or something interrupting the circuit.
Evpjr is offline   Quote Quick Reply
Old 09-22-2012, 07:35 PM   #5
Jeeper
 
T'sTJ's Avatar
 
Join Date: Jun 2010
Location: SoCal
Posts: 97
Images: 7
Thanks Evpjr, I've decided to have the shop come and pick it up on Monday since there fluid all over my driveway. They can have it back for a few days since I spent $1800 and have a 2yr warranty. If the leak never happened I'd look into the hesitation problem, but since it did I'm a bit PO'd.

I will mention the CPS to him though, thx.
T'sTJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 06:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC