Horn Not Working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-21-2013, 06:09 AM   #1
Jeeper
 
Norcal73's Avatar
 
Join Date: Dec 2012
Posts: 304
Horn Not Working

Read the old threads and cant get my answer. 1999 Wrangler horn hasnt worked since I bought it. All fuses good behind glovebox and under hood (although not one designated as horn in manual). Swapped relay with fuel pump relay, proves relay is good. Ran jumper wire directly from battery to each horn itself and get nothing. Trying to bench test horn but apparently dont know what Im doing. Would think direct from positive to one of the two terminals on horns would test horn but nothing. No airbag light issues so thinking I should rule out clockspring. Any help would be greAt on how to verify physical horns are good....thanks in advance

Norcal73 is offline   Quote
Old 03-21-2013, 06:15 AM   #2
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,734
You could very well have a ground issue. You said you ran power from the battery directly to the horns but mentioned nothing about ground. I would check the factory harness that plugs into the horns and see if you are getting power there first. If so then try to figure out if the horns have a good ground (continuity to the frame) If not establish a good ground and try it again.

__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is online now   Quote
Old 03-21-2013, 06:20 AM   #3
Jeeper
 
Norcal73's Avatar
 
Join Date: Dec 2012
Posts: 304
Thanks Big Sarge. Thought about ground but looks like the ground tee's off to the fog light (Sahara) and they work. Direct wire test from battery I thought it unlikely that both horns (2 factory ones under hood) figure theyre both not dead at same time. I will have a helper this afternoon (more hands) so maybe I can do better testing today just need to get on right track.
Norcal73 is offline   Quote
Old 03-21-2013, 06:23 AM   #4
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,734
Sounds good. good luck with it. And remember the fog lights ground through the mount as do the horns (someone chime in if I'm wrong) the branched off wire is probably just the protective circuit that runs back to the fuse panel.
__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is online now   Quote
Old 03-21-2013, 02:28 PM   #5
Jeeper
 
bittercritter's Avatar
 
Join Date: Feb 2012
Posts: 153
Have you ever heard the horn on one of these, its better off not working. JK
bittercritter is offline   Quote
Old 03-21-2013, 02:37 PM   #6
Jeeper
 
Dextreme's Avatar
 
Join Date: Oct 2011
Location: Oregon City, OR
Posts: 4,758
Images: 1
If you have to replace it, find a "Dual note JJBS". They are the good sounding OEM horn.

What does the multimeter show when its connected to the horn's pin and the horn is pressed at the steeringwheel? If you are getting current all the way to the horn, the horn is probably bad.

__________________
'99 Chili Pepper TJ Wrangler "Mistress"
33x12.5 DuraTracs
Zone 4.25"
Dextreme is online now   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:02 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC