Idle problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-30-2009, 06:53 AM   #1
Jeeper
 
Moparnut's Avatar
 
Join Date: Aug 2009
Location: Windsor, Ontario
Posts: 90
Idle problem

2002 Jeep - 4.0 litre - 5 speed manual - 70,000 miles

Jump in the jeep this morning to go to work and the idle is at 2100 rpms. Even when warmed up it does this.
I can get it to reduce to 1400 rpms at a light by dragging the clutch then depressing and will stay at 1400 rpms but the next light it is back to 2100 rpms.

Jeep running fine before this. Usually idled around 700-800 rpms.
No engine light or codes.

Point me in the right direction . You guys have never let me down yet.

Moparnut is offline   Quote
Old 11-30-2009, 07:00 AM   #2
jvc
Jeeper
 
Join Date: Oct 2009
Posts: 338
try cleaning the throttle body and IAC ( Idle Air Control valve )...

jvc is offline   Quote
Old 11-30-2009, 07:51 AM   #3
Show Me Your 8008135!

WF Supporting Member
 
s3nt3nc3d's Avatar
 
Join Date: Oct 2009
Location: Piqua, OH
Posts: 3,641
Send a message via AIM to s3nt3nc3d
Might also have a dirty TPS sensor needing replaced...it may be stuck in the wrong position.
__________________
"We don't build great brakes because we think you don't know how to drive, we build them for the guy on the road in front of you that doesn't." - Black Magic Brakes
s3nt3nc3d is offline   Quote
Old 11-30-2009, 01:06 PM   #4
Jeeper
 
Moparnut's Avatar
 
Join Date: Aug 2009
Location: Windsor, Ontario
Posts: 90
Update

It was just a vacuum line on top of the intake was leaking. The rubber seal was completely split and sucking air. Fixed it and all is good.
Moparnut is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.2 carb problems stray YJ Tech Forum 20 09-29-2014 10:02 PM
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
hi idle problem xethos YJ Tech Forum 9 02-18-2009 10:33 PM
Consistent Idle problem, sputter @ idle-3000 whippet14 YJ General Discussion Forum 5 01-26-2006 07:41 AM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:29 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC