Idle- starting problem 2003 2.4 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-28-2010, 08:04 AM   #1
Jeeper
 
Join Date: Jan 2010
Posts: 18
Idle- starting problem 2003 2.4

I have a 2003 Wrangler 2.4. It has a starting problem when it's cold. I have to have my foot on the gas pedal till it gets warm then it will run and idle fine. I can turn it off and on all day with out a problem if the jeep is warm. But if it's cold I have to give it fuel.

any ideas?

I changed the plugs.
I took off the fuel line to see if it was getting gas. When I puuled the line off there was gas. Then I cranked the engine with out stepping on the gas pedal and gas was flowing.

fred9981 is offline   Quote Quick Reply
Old 01-28-2010, 10:48 AM   #2
Jeeper
 
silvercreek62's Avatar
 
Join Date: Jan 2010
Location: willis,texas
Posts: 41
cold start

your problem is the I. A. C----idle air control solnoid sometimes you can pull them off and clean with brake clean,they get all carbon up,mine did the same thing,or you can buy one there around 100 dollars. As long as your check engine light is not on, iac usually will not set the light
__________________
LIFES A BEACH!
silvercreek62 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.2 carb problems stray YJ Tech Forum 20 09-29-2014 11:02 PM
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
'97 Wrangler Cold Idle / Load Flooding Problem brad07x TJ Tech Forum 1 12-19-2009 12:10 AM
Very Sad I bought a Lemon... Jahaira_JeepYJ89_fan YJ General Discussion Forum 19 07-13-2007 04:01 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC