Incorrect purge flow 97 TJ 4.0 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-03-2013, 03:53 PM   #1
Newb
 
Join Date: May 2013
Posts: 4
Incorrect purge flow 97 TJ 4.0

I acquired a 97 TJ 4.0 5 sp about a year ago. It was a flood vehicle. Next to nothing in it and got it just to have fun on weekends, etc. It runs well, though there are some electrical issues (to be expected). Took through emissions trying to get current registration. Only code was the incorrect purge flow. The technician said the gas cap checked out fine. There don't appear to be any damaged hoses. When I removed the hoses from the solenoid and canister, quite a bit of carbon came out of the hoses and the solenoid. I blew through the hoses to clear them. I've read other posts about clicking sounds from the solenoid. I don't think this one does that. Should it be?

Is there a way to check the solenoid for proper operation?
Should I clean the solenoid? If so, what is the proper method?
Could the problem be the gas cap, even though the tech said it was fine?

TNKeith is offline   Quote Quick Reply
Old 05-03-2013, 03:59 PM   #2
Sponsoring Vendor
 
Morris4x4Center's Avatar
 
Join Date: Sep 2008
Location: Pompano Beach, FL
Posts: 394
Quote:
Originally Posted by TNKeith View Post
I acquired a 97 TJ 4.0 5 sp about a year ago. It was a flood vehicle. Next to nothing in it and got it just to have fun on weekends, etc. It runs well, though there are some electrical issues (to be expected). Took through emissions trying to get current registration. Only code was the incorrect purge flow. The technician said the gas cap checked out fine. There don't appear to be any damaged hoses. When I removed the hoses from the solenoid and canister, quite a bit of carbon came out of the hoses and the solenoid. I blew through the hoses to clear them. I've read other posts about clicking sounds from the solenoid. I don't think this one does that. Should it be?

Is there a way to check the solenoid for proper operation?
Should I clean the solenoid? If so, what is the proper method?
Could the problem be the gas cap, even though the tech said it was fine?
A Fluke Tool would be able to check the solenoid. What was the Code #?

__________________
Morris4x4Center.com
Toll Free: 877.553.5337 | Free Shipping on Orders Over $99!|
PM - with any questions or Price-Matching!
Morris4x4Center is offline   Quote Quick Reply
Old 05-06-2013, 07:16 AM   #3
Newb
 
Join Date: May 2013
Posts: 4
P0441.
TNKeith is offline   Quote Quick Reply
Old 05-06-2013, 03:17 PM   #4
Newb
 
Join Date: May 2013
Posts: 4
incorrect purge flow

I'm interested to know what anyone else is done to correct this problem. Thanks in advance
TNKeith is offline   Quote Quick Reply
Old 05-30-2013, 09:34 AM   #5
Newb
 
Join Date: May 2013
Posts: 4
Fixed

New purge solenoid fixed it.
TNKeith is offline   Quote Quick Reply
Old 05-30-2013, 10:22 AM   #6
Jeeper
 
flflash's Avatar
 
Join Date: Mar 2013
Posts: 519
I hope you replaced the cannister also? Those lil black chunks where carbon/charcoal from the evap cannistor once they start coming apart they'll continue and will stick your new valve.

flflash is offline   Quote Quick Reply
Reply

Tags
evap , p0441 , purge

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC