Intermittent engine bucking problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-08-2010, 04:42 PM   #1
Newb
 
Join Date: Mar 2008
Location: Palo Alto CA
Posts: 13
Intermittent engine bucking problem

So, my Jeep is having this problem where the engine is bucking violently. It has been having this problem intermittently, but lately it seems to have gotten a lot worse. Also, it never throws a CEL. I had thought this was being caused by a bad TPS sensor. About a year ago, I was getting a CEL that said the TPS was bad. So I bought a new sensor and attempted to replace it. I was unable to get the TPS off the throttle body because one of the bolts that holds it on was stripped. Needing to drive the car, I put everything back together with the old TPS sensor, and for some reason the Jeep ran fine. I left it this way the whole time till now, when I started experiencing this bucking issue really bad. So, I think to myself, must be that sensor I never replaced? I already had the new part, so I take the throttle body off, hack off the stripped bolt and replace the sensor. I test drive the car, drove it like 30 miles, and it runs perfect. I'm thinking the Jeep is fixed. Well today,(the day after the test run) my girlfriend calls me to tell the problem is happening again. Anybody have any Ideas on what to look for? Also, when I'm experiencing this problem, the tach and sometimes speedo acts erratically, jumping all over the place, but no change in actual engine speed. This is for a 98 tj 4 liter. I hope this is clear, sorry for the long post Any ideas are appreciated as I'm new to jeeps. Meanwhile I'll be searching

98TJsport is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seafoam? bato TJ Tech Forum 81 03-17-2014 02:37 PM
Phantom Engine Problem dhayes TJ Tech Forum 12 02-04-2011 07:46 PM
Engine transmission problem help Barrett Armorer General Jeep Discussion 0 10-27-2010 02:15 PM
Weird engine problem RhcSavage21 TJ Tech Forum 2 06-26-2009 09:29 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:38 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC