I've got a couple problems... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-02-2011, 05:55 PM   #1
Jeeper
 
CJ7GoldenEagle's Avatar
 
Join Date: Dec 2010
Location: Marseilles, Illinois
Posts: 154
I've got a couple problems...

So, I just got my first Wrangler on Christmas Eve. So far it seems to be doing well...except for 2nd gear, but I guess that's pretty normal. Anyway, I've discovered two problems. The first, and most important, is that the ignition is somehow screwed up and can be operated by pretty much any key. Any ideas about what's wrong or how much that would cost to be fixed? Or is that something that could be done by yourself?

My second problem is with the ventilation system. The selector switch doesn't do anything. Regardless of whether you put it on your feet, windshield, top vents, it still seems like it's just blowing out from somewhere in the dash. What would/could cause this and, again, is this something I could fix myself, or should I even try?

CJ7GoldenEagle is offline   Quote Quick Reply
Old 01-02-2011, 05:56 PM   #2
Jeeper
 
CJ7GoldenEagle's Avatar
 
Join Date: Dec 2010
Location: Marseilles, Illinois
Posts: 154
Oh yeah, it's a '98 Wrangler Sport, just so you know.

CJ7GoldenEagle is offline   Quote Quick Reply
Old 01-02-2011, 05:59 PM   #3
Jeeper

WF Supporting Member
 
Jp90Talon's Avatar
 
Join Date: Dec 2008
Location: CT
Posts: 3,137
Cant help you with the ignition but the blower issue is a common issue. Odds are you need a new resistor or as simple as a vacuum line popped off somewhere. JP magazine did a nice write up on what to do if its the resistor but I need to find the link.
__________________
Jp90Talon is offline   Quote Quick Reply
Old 01-02-2011, 06:07 PM   #4
Jeeper

WF Supporting Member
 
jeepjones's Avatar
 
Join Date: Jul 2010
Location: Canada, Eh?
Posts: 1,892
The ignition switch is worn out thats why just about any key will work, you will have to replace it to fix it.
__________________
jeepjones is offline   Quote Quick Reply
Old 01-02-2011, 06:09 PM   #5
Jeeper
 
TJ Terry's Avatar
 
Join Date: Jun 2010
Location: Minnesota
Posts: 135
Sounds like the blower is working fine, you just cant change the air flow. I would start by looking for a vacuum hose that is sucked flat or broken off. The one going into the firewall. If its good then its most likely the selector switch. As for the ign problem sounds like a bad lock cylinder.
__________________
TJ Terry is offline   Quote Quick Reply
Old 01-02-2011, 06:13 PM   #6
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,947
look upside down under the dash with the heat blowing and feel around for anything that may have came loose. Ducts back in there can get popped off from each other and blow air out in some random direction instead of out through the vents.

Sounds like the ignition (key switch) is wore out or was popped to try and steal it at one point in time. At least you do not have to worry about forgetting your keys andwhere! Just ask someone for theirs to start your jeep with!

__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Clutch Problems and How I Resolved Them linz TJ Tech Forum 7 08-30-2014 06:36 AM
Couple of questions for the experts tn-yj YJ General Discussion Forum 14 10-01-2008 09:25 PM
BD Performance (EBay problems?) MOz General Jeep Discussion 4 04-24-2007 06:51 AM
97 Wrangler SE Problems - Need Some Sound Advice! scleme1 TJ Tech Forum 9 04-05-2007 01:35 PM
buy a couple mil. in equipment, get free toys! TXST8tj Off-Topic 9 02-09-2007 03:08 PM



» Featured Product

All times are GMT -5. The time now is 04:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC