Jeep didn't want to start and kept dying? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-27-2012, 10:40 PM   #1
Newb
 
Join Date: Nov 2012
Location: Greensboro
Posts: 11
Jeep didn't want to start and kept dying?

My jeep is a 1999 2.5 liter 4 cylinder, 103xxx miles on it. Thanks in advance for any help!

Tonight I went outside and drove the jeep 3 minutes from work to the store. I was in the store for maybe 20 minutes and when I came back out the jeep wouldn't crank. I gave it gas to get it to crank and it cranked up, but if I let off the gas it does again. I had to keep giving it gas or it cut right back off. I drove it up the road and for a minute it kept trying to cut off without gas but dafter driving for a minute it drove fine, although idleing low. Any idea what this could be?? Thank you!

99tjnc is offline   Quote Quick Reply
Old 12-27-2012, 10:41 PM   #2
Newb
 
Join Date: Nov 2012
Location: Greensboro
Posts: 11
It died* again, not does again. Sorry for the mistakes, my phone isn't cooperating with the forum tonight. Thanks again!

99tjnc is offline   Quote Quick Reply
Old 12-27-2012, 11:00 PM   #3
Jeeper
 
UFOtestpilot's Avatar
 
Join Date: Nov 2012
Location: Portland, Oregon
Posts: 1,818
Not enough juice for the fuel system would be my first guess. I'd say to test the battery and go from there. I had this issue in mine a while back and it turned out the battery was toast.
__________________
For some, it is easier to kill the light inside of themselves than it is to fight the darkness all around them.
UFOtestpilot is offline   Quote Quick Reply
Old 12-28-2012, 12:41 PM   #4
Newb
 
Join Date: Nov 2012
Location: Greensboro
Posts: 11
It did it once before and it was my battery, and that was back in September. But I replaced the battery then
99tjnc is offline   Quote Quick Reply
Old 12-28-2012, 12:52 PM   #5
Jeeper
 
Neil F.'s Avatar
 
Join Date: Nov 2007
Location: Marlton, NJ
Posts: 5,274
Images: 1
If the battery is weak or bad, the PCM will not allow the engine to run. It will stay running if you keep your foot on it but it will shut off as soon as you let off. Do the obvious first, take the cables off the terminals and clean them to make sure corrosion is not the problem, then take the battery to be tested.
__________________
2003 TJ, 33" BFG AT, 2" BL, 2" BDS spring lift, Truck Lite headlights, Homemade sunrider top.
Neil F. is offline   Quote Quick Reply
Old 12-28-2012, 02:21 PM   #6
Jeeper
 
BigDeaner's Avatar
 
Join Date: Mar 2012
Location: Boston
Posts: 592
As the previous posters have said, check the battery. I had the same exact issue and the battery was junk. Check and clean the terminals, make sure all your connections are tight.

In the process of hunting down my battery issue, I swapped out the IAC, replaced the TPS and cleaned the throttle body. None fixed my issue, but it did lead to a smoother idle.
__________________
'99 TJ Chili Pepper Red SOLD
'13 JKU Rubicon Billet SOLD
BigDeaner is offline   Quote Quick Reply
Old 12-28-2012, 04:25 PM   #7
Newb
 
Join Date: Nov 2012
Location: Greensboro
Posts: 11
Ok thanks for the information, I'll check everything out with the battery first. Thanks!
99tjnc is offline   Quote Quick Reply
Old 12-28-2012, 09:16 PM   #8
Newb
 
Join Date: Nov 2012
Location: Greensboro
Posts: 11
I went and checked the battery and alternator and both are good. I do have a catalytic converter that's making a lot of noise, could this be due to it being clogged or is it more likely something in the engine?

99tjnc is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:34 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC