Jeep dying - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-18-2013, 10:49 PM   #1
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
Jeep dying

So I was driving today and I made a turn and all of a sudden my engine shut off out of nowhere. I still had all my lighting but my car was dead. I checked anything that could cause that does anybody know??? I need help

1998wranglersport is offline   Quote Quick Reply
Old 04-18-2013, 10:56 PM   #2
Jeeper
 
wrangleryj90's Avatar
 
Join Date: Mar 2013
Location: Spokane,Wa
Posts: 495
Are you low on gas?

wrangleryj90 is offline   Quote Quick Reply
Old 04-19-2013, 07:45 AM   #3
Jeeper
 
DarrenT's Avatar
 
Join Date: Aug 2012
Location: New Brunswick, Canada
Posts: 186
Send a message via Skype™ to DarrenT
Does the dash light up when ignition is on, or is it just the interior lights that are on?
Let us have some more info on what it does and doesn't do
DarrenT is offline   Quote Quick Reply
Old 04-19-2013, 08:49 AM   #4
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
Still have half a tank but everything electrical in my car still works all my dash lights turn on just my engine doesn't turn over to start.
1998wranglersport is offline   Quote Quick Reply
Old 04-19-2013, 08:50 AM   #5
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
When I turn the key the engine tries to start but thts all it does
1998wranglersport is offline   Quote Quick Reply
Old 04-19-2013, 09:00 AM   #6
Jeeper
 
DarrenT's Avatar
 
Join Date: Aug 2012
Location: New Brunswick, Canada
Posts: 186
Send a message via Skype™ to DarrenT
could be the CPS, mine went a couple weeks back. Do you have the engine check light on?
DarrenT is offline   Quote Quick Reply
Old 04-19-2013, 09:54 AM   #7
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
Nope the engine light isn't on
1998wranglersport is offline   Quote Quick Reply
Old 04-19-2013, 09:59 AM   #8
Jeeper
 
DarrenT's Avatar
 
Join Date: Aug 2012
Location: New Brunswick, Canada
Posts: 186
Send a message via Skype™ to DarrenT
Quote:
Originally Posted by 1998wranglersport View Post
Nope the engine light isn't on
Well I supposed the first thing I would do (and did) would be to check the function of the distributor, leads and plugs. Ensure you're getting a spark and all the parts are serviceable. Go from there. I got a new CPS from Napa for $40, so in the event it is the CPS, it's not a bank breaker.
I have a PDF of the service manual, if you want a copy you're more than welcome.

Darren
DarrenT is offline   Quote Quick Reply
Old 04-19-2013, 10:16 AM   #9
Newb
 
Join Date: Feb 2013
Posts: 2
First thing I would do would be to check fuel pressure on your fuel rail( assuming its efi). You can do this by turning your key back and forth between the off possion and the run position(not the starting position). You should have good flow along with decent pressure (40-50psi). Would also recommend changing plugs out on it. Take note of the conditions of the color and wear on the plugs. ( new plugs can cure a lot of things more than this and is good for fuel mileage and performance) I would start there and if you Are still having problems feel free to message me...been there done that.
davisrockstar is offline   Quote Quick Reply
Old 04-19-2013, 10:19 AM   #10
Sponsoring Vendor
 
Morris4x4Center's Avatar
 
Join Date: Sep 2008
Location: Pompano Beach, FL
Posts: 401
CPS or a fuse within the ignition system.. Happend on a Nissan years back, boggled my mind cause there was no CEL. Should be anything too crazy, good luck.
__________________
Morris4x4Center.com
Toll Free: 877.553.5337 | Free Shipping on Orders Over $99!|
PM - with any questions or Price-Matching!
Morris4x4Center is online now   Quote Quick Reply
Old 04-19-2013, 10:29 AM   #11
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 537
Send a message via Yahoo to ChaddG
check for corrosion on/in the fuse boxes, wiggle the fuse box.
make sure its not the fuel filter.
I had a ford escort that did the same thing in a turn, turned out to be corrosion on the fuse box wires in the engine next to the battery.
ChaddG is offline   Quote Quick Reply
Old 04-19-2013, 10:37 AM   #12
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
I'll check all that but I might change the spark plugs and see what that does they are old and I will check anything possible. All my fuses are still good I checked those fuel filter ill check too. Anything else?
1998wranglersport is offline   Quote Quick Reply
Old 04-19-2013, 10:46 AM   #13
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
Quote:
Originally Posted by DarrenT View Post

Well I supposed the first thing I would do (and did) would be to check the function of the distributor, leads and plugs. Ensure you're getting a spark and all the parts are serviceable. Go from there. I got a new CPS from Napa for $40, so in the event it is the CPS, it's not a bank breaker.
I have a PDF of the service manual, if you want a copy you're more than welcome.

Darren
Could I get a copy of it???
1998wranglersport is offline   Quote Quick Reply
Old 04-19-2013, 10:56 AM   #14
Jeeper
 
DarrenT's Avatar
 
Join Date: Aug 2012
Location: New Brunswick, Canada
Posts: 186
Send a message via Skype™ to DarrenT
PM sent.

Service Manuals
DarrenT is offline   Quote Quick Reply
Old 04-19-2013, 03:14 PM   #15
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
Quote:
Originally Posted by DarrenT View Post
Awesome thanks
1998wranglersport is offline   Quote Quick Reply
Old 04-20-2013, 02:42 PM   #16
Jeeper
 
1998wranglersport's Avatar
 
Join Date: Mar 2013
Posts: 28
where is the c103, s128 and s126 wires???

1998wranglersport is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:43 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC