Jeeps rough idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-08-2013, 09:14 PM   #1
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
Jeeps rough idle

Ok so a few days ago my jeep started acting funny first as I was driving I noticed the voltage was rising as I accelerated and the check gauges light came on I got home shut it off and tried to start it again and I got nothing no turn over no click zero after a few tries it started I cleaned the battery cables and had the alternator and battery checked they were fine. After the cleaning it hasn't done it since but a new development started its running really rough at start up it runs fine at highway speeds but at idle it sputters and the Rpms bounce a little. I have already cleaned the iac and throttle body, ran cleaner through
The injectors. Checked the spark plugs still running rough am I missing something. Any
Help would be greatly appreciated

Mikes jeep is offline   Quote Quick Reply
Old 09-08-2013, 09:23 PM   #2
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
Forgot to mention its a 03 tj automatic 4.0 with 94.000 on it always ran Mobil one synthetic.

Mikes jeep is offline   Quote Quick Reply
Old 09-09-2013, 09:32 AM   #3
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
Quote:
Originally Posted by Mikes jeep View Post
Ok so a few days ago my jeep started acting funny first as I was driving I noticed the voltage was rising as I accelerated and the check gauges light came on I got home shut it off and tried to start it again and I got nothing no turn over no click zero after a few tries it started I cleaned the battery cables and had the alternator and battery checked they were fine. After the cleaning it hasn't done it since but a new development started its running really rough at start up it runs fine at highway speeds but at idle it sputters and the Rpms bounce a little. I have already cleaned the iac and throttle body, ran cleaner through
The injectors. Checked the spark plugs still running rough am I missing something. Any
Help would be greatly appreciated
Update:
This morning the check engine light came on code p0304 misfire number 4 cylinder
Mikes jeep is offline   Quote Quick Reply
Old 09-09-2013, 09:33 AM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 30,867
Images: 2
I'm thinking bad 02 sensor or bad pre-catalytic converter. Mine did the same thing.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 09-09-2013, 10:22 PM   #5
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
Turns out it was bad plugs I replaced them last year I guess it didn't like the ones I got put in new ones today and check engine light turned off and it started idling better than when I got it
Mikes jeep is offline   Quote Quick Reply
Old 09-09-2013, 10:25 PM   #6
Jeeper
 
Endoftheroad4x4's Avatar
 
Join Date: Jul 2013
Posts: 119
Distributor cap? And wires?
Endoftheroad4x4 is offline   Quote Quick Reply
Old 09-09-2013, 11:06 PM   #7
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
No cap or wires on an 03
Mikes jeep is offline   Quote Quick Reply
Old 09-09-2013, 11:46 PM   #8
Jeeper
 
rkulp89's Avatar
 
Join Date: Aug 2013
Posts: 57
Were your gaps set right when you replaced last or did u just drop them in?
rkulp89 is offline   Quote Quick Reply
Old 09-10-2013, 07:44 AM   #9
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
They were set right last year before I replaced them yesterday I even took them out to check again they didn't look that bad to me kinda ashy but not all blackened
Mikes jeep is offline   Quote Quick Reply
Old 09-10-2013, 08:26 AM   #10
Jeeper
 
louczar's Avatar
 
Join Date: Aug 2013
Location: NB, TX
Posts: 178
I call foul :-)
__________________
Just because you have one doesn't mean you have to act like one :-)

2012 VW Jetta TDI (90+ mile commute round trip to work) DD
2002 Wrangler X (in my name and waiting for my son to move from permit to license)
louczar is offline   Quote Quick Reply
Old 09-10-2013, 07:38 PM   #11
Jeeper
 
Endoftheroad4x4's Avatar
 
Join Date: Jul 2013
Posts: 119
Quote:
Originally Posted by Mikes jeep View Post
Turns out it was bad plugs I replaced them last year I guess it didn't like the ones I got put in new ones today and check engine light turned off and it started idling better than when I got it
Were they Bosch double platinum plugs?
Endoftheroad4x4 is offline   Quote Quick Reply
Old 09-10-2013, 07:57 PM   #12
Newb
 
Mikes jeep's Avatar
 
Join Date: May 2013
Posts: 13
Ya when I got it I didn't know much about keeps thought the more expensive ones would be better. Drove the jeeps today still has a little rough spot but no where near as bad as it was

Mikes jeep is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC