Lack of performance - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-16-2009, 09:17 AM   #1
Newb
 
Join Date: Nov 2009
Posts: 2
Unhappy Lack of performance

I have a 2.4 wrangler jeep 2004,since it was new it has never felt like it has been running well, it coughs and splutters in low revs and generally feels like it is down on power. Chrysler (malaga spain) have said it is ok but I have lost all confidence in them as I am not sure they know what they are doing.
Does anybody have any reccommendations other than I should have bought the bigger engine!!

Yeatsey is offline   Quote Quick Reply
Old 11-16-2009, 09:25 AM   #2
Jeeper
 
adkjoe's Avatar
 
Join Date: Aug 2009
Location: Northern Vermont
Posts: 1,615
I have posted a bunch of times about this, mine does the exact same thing at low rpms, especially if I'm stopped on a hill and try to get going. I have changed plugs, wires, cleaned throttle body, checked fuel pressure, etc...and while all made a small difference it still sputters and coughs at low rpms, i'm pretty convinced that's just how the 2.4L is. I've gotten used to revving it before taking off. Others with the 2.4L will tell you the same thing. If you figure it out please let me know because I'm dying to fix it (if it's fixable).

adkjoe is offline   Quote Quick Reply
Old 11-16-2009, 09:29 AM   #3
Jeeper
 
mudslinger150's Avatar
 
Join Date: Jul 2009
Location: Northern VT
Posts: 1,128
Images: 1
most 4.0L's do that same thing on initial start up, mine does
__________________
Mitch

Vermont
The Green Mountain State

http://www.cardomain.com/ride/3821222

http://www.youtube.com/watch?v=20dGUB6uJcQ
mudslinger150 is offline   Quote Quick Reply
Old 11-16-2009, 09:34 AM   #4
Jeeper
 
adkjoe's Avatar
 
Join Date: Aug 2009
Location: Northern Vermont
Posts: 1,615
IDK about Yeatsey but mine doesn't do it on initial start up it does it whenever I'm stopped at a light idling and go to take off or if I try and punch it to get up to speed. It's fine on start up.
adkjoe is offline   Quote Quick Reply
Old 11-20-2009, 09:15 AM   #5
Newb
 
Join Date: Nov 2009
Posts: 2
Thumbs down Yeatsey

Its fine on start up its just the rest of the time!
Yeatsey is offline   Quote Quick Reply
Old 11-20-2009, 09:26 AM   #6
Jeeper
 
adkjoe's Avatar
 
Join Date: Aug 2009
Location: Northern Vermont
Posts: 1,615
Quote:
Originally Posted by Yeatsey View Post
Its fine on start up its just the rest of the time!
I hear ya, no one seems to know, I have asked the same question a bunch of times. I have tried numerous things, I have just learned to live with it.

Highway....headwind....steep hill.....2.4L.....priceless.
adkjoe is offline   Quote Quick Reply
Old 11-20-2009, 09:35 AM   #7
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,701
My 2.4 only sputters once after fueling up. Other than that it's pretty smooth. Over 77k and going strong.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is online now   Quote Quick Reply
Old 11-20-2009, 09:40 AM   #8
Jeeper
 
adkjoe's Avatar
 
Join Date: Aug 2009
Location: Northern Vermont
Posts: 1,615
your lucky I can't figure mine out. 43K and sputters and coughs like a bastard. Fine in 4lo but other than that the motor at low rpms runs like crap.
adkjoe is offline   Quote Quick Reply
Old 11-20-2009, 09:47 AM   #9
Jeeper
 
Join Date: Oct 2009
Location: San Diego
Posts: 759
regear? just a random input, I dont own a 2.4L and never will = )

terrible2 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone used performance chips from PCD? KTC YJ Build Forum 8 04-29-2013 11:03 AM
88 wrangler 4 cyl iat performance mod cn.anglin YJ Tech Forum 4 10-20-2009 12:55 PM
505 performance turbo kit laxin15 TJ General Discussion Forum 7 08-29-2009 12:40 PM
performance chip amoujaffar YJ Tech Forum 11 08-10-2009 12:01 AM
how do I get more performance from my 2006 4.0ltr Wrangler ironman01 TJ Tech Forum 15 03-27-2009 02:33 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC