Loooow Power - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-10-2010, 11:47 AM   #1
Jeeper
 
Spooled's Avatar
 
Join Date: Jul 2010
Location: Mobile, AL
Posts: 30
Loooow Power

Hey guys, last month i posted up about my 2006 Wrangler Sport I6 with the check engine light on. I checked the codes and got the following...P0031, P0037, P0051, P0057 all indicating Heat Circuit Low? I replaced the O2 sensors and still had the same lights on.

I had noticed that the Jeep was a little sluggish, especially when i ran the a/c. Last month I changed the plugs, air filter, oil, and gear oil as well. i drove the Jeep 160 mile last night when it started loosing power fast. The check engine light blinked a couple of times and I gradually lost speed down to 35 mph on the interstate. I limped to the rest area ahead and called my buddy to tow it back for me.

It idles fine, I just have no power. With the o2 sensor codes would it possibly be plugged cats? I was also leaning toward a fuel flow issue? My fuel gauge has not been working, sending unit/filter?

Any ideas where to start?

__________________
-=Rick
Mobile, AL

2006 Solar Yellow Jeep Wrangler 6speed
Spooled is offline   Quote
Old 09-10-2010, 10:15 PM   #2
Jeeper
 
Spooled's Avatar
 
Join Date: Jul 2010
Location: Mobile, AL
Posts: 30
I since swapped the plugs with NGK's and still have the same results.
__________________
-=Rick
Mobile, AL

2006 Solar Yellow Jeep Wrangler 6speed
Spooled is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power acordell TJ Tech Forum 13 02-16-2010 06:26 AM
No engine power on a new JK unlimited vincan JK General Discussion Forum 43 01-24-2010 09:06 PM
2001 TJ - Auxiliary Power (Switched) - Problem jordan.cook TJ General Discussion Forum 10 12-22-2009 07:16 AM
Linear amp Question silvergoat Communications and Electronics 19 11-07-2008 05:11 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:56 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC