Losing power when hot - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-01-2009, 04:14 PM   #1
Newb
 
Join Date: Mar 2009
Posts: 2
Losing power when hot

Just purchased a 4 cylinder 1990 Wrangler that had been sitting for a long time (several years). Driving it back home, it lost considerable amount of power after 1 hour of driving. Stopped and replaced the fuel filter, A lot of trash came out. Jeep ran fine for about 40 minutes, then lost power again. Replaced the fuel filter again, same results (losted power after 30 minutes) Stopped for gas, had lunch, Jeep ran fine again for about 30 minutes. Iím thinking that the problem it not trash in the fuel filter, but some electrical component that gets hot and causes the power loss. Any ideas what the problem could be, coil, Ignition Control Unit , catalytic converter, or some other component? Any help would be greatly appreciated. Thanks

cyclebender is offline   Quote Quick Reply
Old 04-01-2009, 04:21 PM   #2
Jeeper
 
daanbc's Avatar
 
Join Date: Mar 2009
Location: Palm Beach Fl.
Posts: 815
Images: 2
I'd say the cat. converter. If the fuel filter is not clogged.

daanbc is offline   Quote Quick Reply
Old 04-01-2009, 04:52 PM   #3
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
I'd second that motion.

Once the cat is blocked up or pretty much fallen apart inside, it's a huge restriction. Get it replaced or removed if legal in your area.
AzTJ is offline   Quote Quick Reply
Old 04-01-2009, 04:58 PM   #4
Wrecktrician
 
4point's Avatar
 
Join Date: Dec 2006
Location: Central Sierra
Posts: 7,351
Critters can make home in funny places too. Intake systems, HVAC systems, exhaust systems......... They eat wiring and other plastic and rubber parts..........
__________________
Just getting to work is an adventure.
4point is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power acordell TJ Tech Forum 13 02-16-2010 06:26 AM
Losing lots of power on highway atj54 YJ General Discussion Forum 10 09-17-2009 04:54 AM
intermittant power to fuel pump skeeter General Jeep Discussion 4 02-08-2009 08:22 PM
Linear amp Question silvergoat Communications and Electronics 19 11-07-2008 05:11 PM
poping sound and losing power pensfan28441 YJ Tech Forum 4 12-10-2007 08:06 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:55 AM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC