Low oil pressure when warm was the... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-19-2011, 11:49 PM   #1
Jeeper
 
MLaborde's Avatar
 
Join Date: Feb 2011
Location: East Texas
Posts: 427
Low oil pressure when warm was the...

sending unit. Thank goodness! I put on a new one today and, while it still drops at idle, it doesn't even drop to 20. Oddly enough, it runs at a little over 50 under power where it was running a little over 40 before.

Is it possible that this unit just moved both the low mark and the high mark a little higher? Anyway, at least I'm not as worried anymore.

Now, I need some more advice:


My first run after replacing the sending unit I got some hesitation under acceleration and 2 skips from the engine. My 75 year old neighbor that I was giving a ride heard it too. I had already driven 100 miles today without it doing that before than. Could changing out the oil sending unit have caused that.

Also, the Jeep seems to respond immediately when I turn the steering wheel and feels tight in a curve but seems to want to wiggle side to side while I'm driving straight. That is the feeling I felt the other morning when I was bitching on here about it feeling like I was driving in a really strong crosswind. Ideas, anyone?

Now, if the mechanic can just get rid of the scraping noise from the rear when he replaces the clutch Monday and find out why it sounds like a Volkswagen when I accelerate, I'll be happy. I'm gonna ask him to check the front end too.

MLaborde is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'94 4.0L/I6 Funky Oil Pressure Indication??? atomicjoe23 YJ Tech Forum 9 10-07-2011 11:09 PM
Oil Pressure drop, DD need help quick! Under the Palms TJ Tech Forum 12 10-04-2010 04:56 PM
Low oil pressure at idle 97tjcse TJ Tech Forum 9 08-24-2009 11:12 PM
Really HIGH oil pressure in cold BlackJeepoftheFamily TJ General Discussion Forum 8 11-19-2008 10:26 PM
Oil pressure sender, replaced, I think.... Black02M3 TJ Tech Forum 12 03-19-2008 08:58 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:58 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC