Misfire Somewhere? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-17-2012, 11:05 AM   #1
Sammy91683's Avatar
Join Date: Jun 2011
Location: Northern California
Posts: 159
Misfire Somewhere?

When I'm at idle, a random ticking sound starts happening. I'm not able to hear it if I'm driving since the engine and road noise is way louder. You can hear it if you park and lift the hood. Also, when the ticking noise happens, the engine rumbles like there is a misfire.

Sammy91683 is offline   Quote
Old 08-02-2012, 11:35 AM   #2
prettyinpink's Avatar
Join Date: Jul 2012
Location: Simi Valley
Posts: 52
Im having same issue. Impulling out my exhaust and checking cats tonight.

prettyinpink is offline   Quote
Old 08-02-2012, 11:42 AM   #3
Rubicon2's Avatar
Join Date: Nov 2010
Location: Northern Lower Michigan
Posts: 1,360
EVAP purge valve clicking, its normal and may cause a slight stumble in the engine when it opens and closes. Also check your IAC and make sure it is clean. Just some suggestions.
Rubicon2 is offline   Quote

misfire , ticking

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:34 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC