Misfiring Question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-16-2010, 03:59 PM   #1
Jeeper
 
Mclaughlin_1234's Avatar
 
Join Date: Jan 2009
Location: Boston
Posts: 165
Misfiring Question

Alright this is gonna be a long one...Please read

So the past couple mornings ive been getting up for work and when i start up my 2004 I6 it would be very rough, But as soon as i touch the gas it would go back to normal with a little choppyness. So when im driving its fine. So this morning i get up and the check engine light is on, So i pull the code and it says im missfiring out of my 6th cylinder.So i imedatly drive to autozone buy plugs,gaped them perfectly and then put it in. Now i start up my jeep and it starts right up but the engine light is on,Now im thinking to my self crap forgot to disconect the battery,so i do that and the light obv goes away,ive driven about 20 miles now and it hasnt come back on,but my rpms are fine when im at a stop but my exhaust sounds like i have an agressive came in it or something,What should i do,should i stop driving it? sorry for my spelling!

Mclaughlin_1234 is offline   Quote Quick Reply
Old 06-16-2010, 04:27 PM   #2
Jeeper
 
Indy's Avatar
 
Join Date: Jun 2009
Location: Bay Area
Posts: 554
I think your TPS might be going bad. Does it still sound like that at higher RPMs? If not, then you it should be safe to drive it around.
__________________
98 TJ 4.7 Stroker!!! Unichip tuner, HPD30/D44, 4.56, Detroit Locker in rear axle, 3.25RC SL, 1.25BL, 1MML, 35x12.50x15, Cager Softs 15x8, XRC10 winch, Rancho 9000XL shocks with wireless remote
Indy is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
6sp shift question rico334 TJ Tech Forum 15 12-13-2009 09:08 PM
quick axle question Sb5551 TJ Tech Forum 3 10-03-2008 08:38 PM
Trans Mount Question MOz TJ Tech Forum 8 06-10-2008 03:14 PM
Tub liner question.... KBR97 General Jeep Discussion 3 06-01-2008 12:29 AM
Carb question and EGR question trulefty YJ Tech Forum 0 12-12-2006 04:55 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:10 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC