missing - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-06-2013, 07:13 PM   #1
Jeeper
 
Join Date: Aug 2009
Location: Valdosta GA
Posts: 27
missing

I have a 2004TJ 2.4 and I have a miss or rough running until 28k rpm. As soon as it hits 28k rpm without fail it smooths right out. It has 34k miles on it. I only drive it about once a week so I thought maybe a dirty injector, I put 2 tanks thru it with some injector cleaner in it with no change. Any suggestion on where to start?

noljohn is offline   Quote
Old 07-06-2013, 07:53 PM   #2
Jeeper
 
Slater451's Avatar
 
Join Date: Oct 2012
Location: Syracuse NY
Posts: 1,017
Check your plug wires... Pull them off and fill up the ends with dielectric grease and put them back on. I have a similar problem every now and then...the wire will ark from the tip of the plug to the socket nut part.... You'll see a black charred strip the looks like a crack... Also it wouldn't hurt to swap out the plugs with an new set of NGKs

Slater451 is offline   Quote
Old 07-06-2013, 08:03 PM   #3
Jeeper
 
Join Date: Mar 2011
Posts: 428
28,000RPM? That's really fast. I think you meant 2800RPM, or 2.8K.
__________________
Gary
1967 Kaiser Commando
2001 Grand Cherokee WJ
2003 Rubicon TJ
KaiserJeep is offline   Quote
Old 07-06-2013, 08:05 PM   #4
Jeeper
 
eagle223's Avatar
 
Join Date: Jun 2011
Location: Bay Area, CA
Posts: 515
Quote:
Originally Posted by Slater451 View Post
Check your plug wires... Pull them off and fill up the ends with dielectric grease and put them back on. I have a similar problem every now and then...the wire will ark from the tip of the plug to the socket nut part.... You'll see a black charred strip the looks like a crack... Also it wouldn't hurt to swap out the plugs with an new set of NGKs
There aren't plug wires on an 04, they switched from distributor ignition to coil pack or distributor less ignition systems in 2000
eagle223 is offline   Quote
Old 07-06-2013, 08:23 PM   #5
Jeeper
 
Slater451's Avatar
 
Join Date: Oct 2012
Location: Syracuse NY
Posts: 1,017
That's the 4.0.... The 2.4L has plug wires.... I've got plug wires on my 06... So I'm sure the OP does as well..
Slater451 is offline   Quote
Old 07-06-2013, 08:50 PM   #6
Jeeper
 
eagle223's Avatar
 
Join Date: Jun 2011
Location: Bay Area, CA
Posts: 515
Quote:
Originally Posted by Slater451 View Post
That's the 4.0.... The 2.4L has plug wires.... I've got plug wires on my 06... So I'm sure the OP does as well..
Didn't know that, figured they would've made it standard across the engine line
eagle223 is offline   Quote
Old 07-07-2013, 03:10 PM   #7
Jeeper
 
Join Date: Aug 2009
Location: Valdosta GA
Posts: 27
missing

Thx for the replies, gives me something to start on. I did mean 2800 rpm. I'll let you know what I find.

noljohn is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:04 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC