motor noise - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-04-2008, 05:42 AM   #1
Newb
 
Join Date: Oct 2008
Posts: 8
Question motor noise

I just bought a 97 wrangler 4.0 5spd with 120k miles on it. The motor doesnt smoke and runs great. When I first crank it up 20 seconds later I get a rattle out of the motor until I take off and then its gone. My oil pressure is fine so I am thinking a lifter might be leaking down. It idles quite at red lights so what do yall think?

georgiaj is offline   Quote
Old 10-04-2008, 10:09 AM   #2
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
Gennerally speaking, things that happen only when cold are by their nature, enviornmental. I'd go with the fuel system first. Dirty fuel filter, semi-bad sensor somewhere etc.

A lifter going out should get worse when it heats up instead of better. You can "mask" that by using a different motor oil etc, but this sounds more like fuel or bad input into the computer via a sensor.
stevens243 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC