need help!!!! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 01-21-2009, 02:59 PM   #1
Join Date: Mar 2008
Location: Kenmore, Wa
Posts: 10
need help!!!!

About the jeep: A few months ago i bought my first wrangler. its used, has about 90,000 miles on it, its a '97 and it is the 4.0 I6 and it looks to be in great condition. its lifted about 3 inches and has 32X11.5 mud terrain tires. the guy i bought it from said that he did the lift himself and installed the new clutch himself. He told me the only problem was an out O2 sencer.
Problems: one buy one problems began. when i start out in first gear it seems to slip and then when it finally grabs it makes a loud rattling noise underneath me and in front of me. I also have a loss in power, especially going up large hills and on the freeway. the front end seems to feel a little lose and on the freeway i encounter the infamous death wobble. i also noticed when rotating my tires that the front right tire has uneven tread wear. then i noticed that when slowing down in 3rd and 2nd gear i hear what seems to be a grinding noise or a rattling noise (could be the cracked muffler, idk). The check engine light is on but it isn't always on. Do you guys think that the lift and clutch are the problems? or could this be a more serious problem?

goodwin2112 is offline   Quote
Old 01-21-2009, 03:21 PM   #2
Giancarlo's Avatar
Join Date: Jul 2006
Posts: 697
Send a message via AIM to Giancarlo
check engine light will go on and off with your o2 sensor especially if you let ur jeep warm up for a good amount of time.. replacing that sensor takes literally 10 min and 60 dollars.. it will also help ur fuel economy

1997 TJ, 6cyl, 4' Skyjacker, Custom Bumpers Front and Rear , Rocker Rails, Magna Flow Muffler, Light Bar , Custom Intake, Optima Yellow Top ,33x12.5x15 Procomp X-Terrain, Alpine Type S Audio, 10' polk sub, Recaro Seats.
Giancarlo is offline   Quote
Old 01-21-2009, 05:19 PM   #3
Lost in Space's Avatar
Join Date: Apr 2008
Location: Meriden, CT
Posts: 24
Didn't you take this Jeep for a test drive before you paid money for it? It sounds like you are noticing stuff now that would be readily apparent once you drove it. I hope changing the O2 sensor will help with some of your problems but it sounds like the clutch is bad. I wish you the very best of luck straightening it out. Don't give up, somewhere under the problems is a great Jeep trying to get out.

-My only problem is I keep forgetting the things I can't remember-
Lost in Space is offline   Quote
Old 01-21-2009, 06:07 PM   #4
Join Date: Jan 2009
Location: spearfish
Posts: 4
mine did the same thing. loss of power and the rattle. My cat. converter was bad and i changed that and got all my power back
brandondykzeul is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:11 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC