need help diagnosing problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-19-2010, 08:34 AM   #1
Jeeper
 
Join Date: Jul 2010
Location: Raleigh, NC
Posts: 35
need help diagnosing problem

99 2.5L

I cannot seem to pin down this problem and its driving me crazy! The car starts up and runs no problems, rev it up in the driveway no probelm still, no codes... Then you get to driving it and it bogs/chokes when you give it a lot of gas while accelerating, and at times even enough to shut off. Then it won't restart unless you keep giving it gas for over a minute, and sometimes doesn't even restart. If you drive the car like a granny you don't notice the issue as much, but the problem is still there. The guy I bought it from said he had it taken to a shop and they tested every sensor (not sure how accurate this is though) and they told him it was the fuel pump. I have fuel pressure at the rails and you can hear the pump engage when you turn the key over. Replaced the spark plugs and MAP sensor already, but no help. What kills me is it isn't throwing any codes.. and sometimes feels like a misfire, but could be fuel related also. Anyone have any ideas?

dmw319 is offline   Quote Quick Reply
Old 07-19-2010, 08:43 AM   #2
Jeeper
 
castorj29's Avatar
 
Join Date: May 2010
Location: Redmond,Oregon
Posts: 579
Maybe your injectors need to be cleaned out.

castorj29 is offline   Quote Quick Reply
Old 07-19-2010, 01:35 PM   #3
Jeeper
 
Join Date: Jul 2010
Location: Raleigh, NC
Posts: 35
Quote:
Originally Posted by castorj29 View Post
Maybe your injectors need to be cleaned out.

ive done this.
dmw319 is offline   Quote Quick Reply
Old 07-19-2010, 02:01 PM   #4
Jeeper
 
A_Mason's Avatar
 
Join Date: Jun 2010
Location: Williamston, MI
Posts: 17
Maybe you've already done this but I'd start with a general tune-up. Cap, rotor, plugs, wires, coil, and air cleaner. After that start chasing the more expensive options. If there are no codes then it should be the basics: air, fire and fuel.
__________________
-----------------
1 Wife, 4 Sons, 1 Jeep
A_Mason is offline   Quote Quick Reply
Old 07-19-2010, 03:32 PM   #5
Jeeper
 
Join Date: Jul 2010
Location: Raleigh, NC
Posts: 35
yea, checked all the basic stuff. new plugs/wires yesterday also
dmw319 is offline   Quote Quick Reply
Old 07-19-2010, 04:02 PM   #6
Jeeper
 
flatline's Avatar
 
Join Date: May 2010
Location: pinole ca.
Posts: 680
Images: 3
just worked on a 94 that would hesitate when given wide open throttle and under load. checked fuel rail presure and was good. changed fuel filter and problem went away. may have presure but not volume.

flatline is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 01:03 AM
electrical problem...help!!! evas98tj TJ Tech Forum 3 10-10-2008 10:18 PM
42RLE Tranny Problem nicolas-eric TJ Tech Forum 8 09-21-2008 06:29 PM
Heater / Blower Problem 2000 Wrangler dougman1971 TJ Tech Forum 0 09-17-2008 07:56 AM
Window Crank woes, did any one else have this problem? virtual_verve11 JK Tech Forum 2 04-07-2007 09:57 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:53 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC