Need Help Dome lights flashing on and off.. - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-19-2013, 08:54 PM   #1
Newb
 
Shortstuff's Avatar
 
Join Date: Jun 2013
Posts: 8
Need Help Dome lights flashing on and off..

Alright guys i have 01 Wrangler and the issue im having is when im driving mainly on highway (seems to be related with higher speeds) my dome lights will come on and start flashing on and off without me doing anything at all and at times they will stay on till i come to a stop.. Now this usually doesnt happen driving through town and around speeds 40 and below but every morning i take the highway to work and run speeds of 50 and 55 and this is normally when it happens.. Very weird, now my dome lights wont work when my doors are open which i done some research and found out somebody had pulled the fuse for the door switches assuming so they can take the doors off which is fine.. The only time my domes will come on is the time when i turn off the switch and pull the key out they will pop on for that time delay then go off and when i manually turn them on with the light switch on the steering column.. Im usually very mechanically and electrically inclined but this one has me stumped, any suggestions things to look at or anybody else that has had this experience please help me.. Anything will be appreciated. Thanks.. oh and also idk if this would be related or not but the light on the dash that shows whether or not your headlights are on or not stays on all the time seems to be some connection problem in the switch itself cause i can mess with it and get it to blink and sometimes go off for a second but comes back on and stays on.. Thanks in advance for any help..

Shortstuff is offline   Quote
Old 08-21-2013, 07:27 PM   #2
Newb
 
Shortstuff's Avatar
 
Join Date: Jun 2013
Posts: 8
bump anything?

Shortstuff is offline   Quote
Old 08-21-2013, 07:47 PM   #3
Jeeper
 
brokejeep's Avatar
 
Join Date: Oct 2009
Posts: 259
I had a truck that did something like this & it was the buttons in the door jam had dirt in them. I took them out & sprayed them full of electric spray cleaner worked them in & out several times & problem solved.
brokejeep is offline   Quote
Old 08-21-2013, 08:20 PM   #4
Newb
 
Shortstuff's Avatar
 
Join Date: Jun 2013
Posts: 8
well the fuse for the door switches is removed they dont work anyhow. Thanks for the suggestion tho i will check again to make sure..
Shortstuff is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:44 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC