Need help guys! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-04-2012, 11:06 AM   #1
Newb
 
Join Date: Jul 2012
Location: ct
Posts: 3
Question Need help guys!

So winter is upon us and I have put the hard top on my 97 TJ. I have only owned this jeep for about 6 months. I have noticed that the roof rattles. There seems to be a gap where the roof and windshield meet ( on the highway all you hear is wind) The quick connect clamps also seem loose and rattle. I have called Quadratec they say there are no parts to fix this. I think I am missing a piece. Please help.

1997 inline6 is offline   Quote
Old 12-04-2012, 11:19 AM   #2
Jeeper
 
hosejockey61's Avatar
 
Join Date: Oct 2012
Location: Aurora, CO
Posts: 2,369
Did you have a bikini top channel still installed on your windshield that you put the hard top over by chance? That would need to be removed prior to the hard top being put on...just a thought

hosejockey61 is online now   Quote
Old 12-04-2012, 11:26 AM   #3
Newb
 
Join Date: Jul 2012
Location: ct
Posts: 3
To be honest.. that could be possible. Do you know if there is supposed to be some sort of weather stripping or something? I will have to take the top off when i get home but If I remember correctly it was just bare mettle above the windshield.
1997 inline6 is offline   Quote
Old 12-04-2012, 02:54 PM   #4
Jeeper
 
hosejockey61's Avatar
 
Join Date: Oct 2012
Location: Aurora, CO
Posts: 2,369
Double check for the bikini top channel. Your top should fall right into place once you get that out. Some channels use screws and some don't.
hosejockey61 is online now   Quote
Old 12-04-2012, 04:08 PM   #5
Jeeper
 
Join Date: Apr 2009
Location: Wolf Lake, IL
Posts: 768
If your front latches rattle it sounds like your missing the rubber/foam strip piece that goes along the top of the windshield frame. Aftermarket headers sit on top of this piece, at least my Bestop header does. Sorry if I'm wrong about your situation but that soft rubber factory strip should make the latches tight when clamped down. Good Luck.
JeepnJim is offline   Quote
Old 12-04-2012, 04:32 PM   #6
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 37,295
Sometimes the hard top is installed incorrectly, maybe the previous owner didn't know what he was doing. When mounting the hard top, it is slid forward on the tub as far as possible so it rests solidly on the top of the windshield frame. Then its two clamps are secured. Then and only then are the rear bolts that hold it to the tub inserted & tightened down.

__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:47 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC