Need Help Now Please!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-24-2009, 06:04 PM   #1
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
Need Help Now Please!!!

I was swapping out bulbs in the gauge cluster just now, and something really bad hapened.

I can't get anything to light up now. I mean NOTHING! The only things that will light up are the seatbelt, airbag, and engine light upon start up. One turn signal works, and noth the other. The lights in my climate controls won't even light up. I tried reversing all the polarities, and nothing.

Any ideas, what's gonig on?

__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 06:10 PM   #2
Jeeper
 
afrats's Avatar
 
Join Date: Dec 2008
Location: Colorado Springs, CO
Posts: 1,531
Send a message via MSN to afrats
Fuses?

__________________
My strength is made
perfect in weakness.
2 Corinthians 12:9


afrats is offline   Quote Quick Reply
Old 01-24-2009, 06:16 PM   #3
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
Fuses?

What would cause a fuse to go like that for no reason?
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 06:18 PM   #4
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
Plus, One blinker working, and the other not???? (im talking about the blinker lights inside. out side everything fine) I'm baffled.
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 06:29 PM   #5
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
check the fuses first definatly, or the connection is not right behind the cluster.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 01-24-2009, 06:34 PM   #6
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
evrything is hooked up solid. odometer comes on fine, engine light, seat belt, but nothing else. and it's affecting the climate control lights as well. that's completely separate.
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 06:59 PM   #7
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
i pulled the cluster fuse, that disabled the seat belt, engine and odometer. i also pulled the panel lmp fuse, obviousley no way to know the differece other than looking at it. it was a bit black, so maybe thats the problem. i sure hope thats all it is. im going to go pick one up right now.

but why would one blinker light work and not the other? that doesn't make any sense to me. ?????
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 07:06 PM   #8
Jeeper
 
NHEric's Avatar
 
Join Date: Jul 2007
Location: Barrington, NH
Posts: 141
dimmer? It doesn't explain the blinker, but it does explain the rest.
NHEric is offline   Quote Quick Reply
Old 01-24-2009, 07:10 PM   #9
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
there is no real plausible pattern on the elctrical circuits, there's actually a lot more on each circuit than the description. the fuse is probably all it is.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 01-24-2009, 07:39 PM   #10
Jeeper
 
Jma20a's Avatar
 
Join Date: Apr 2007
Location: Fairfield, CT
Posts: 3,046
did you clean the connections on the back of the cluster before re-installing it? i had a few issues when i changed my bulbs.
__________________
Dear Algebra, Please stop asking us to find your X. She's never coming back and don't ask Y.
Jma20a is offline   Quote Quick Reply
Old 01-24-2009, 09:32 PM   #11
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
WHAT A CLUSTER F#$K!

It turns out that it was a fuse, BUT MORE THAN ONE. The LEDs were popping the Panel Light fuse every time @10amps. So I decided to put the OEM bulbs back in and just use those since they worked. No Luck. WTF?

As it turns out, the LEDs were popping the Parking Lamp fuse as well. Why? Who knows. And for some reason, if the Parking Lamp fuse is popped, the Panel Lights wouldn't come on even when it had a good fuse in there. WTF?
It took alot of cursing, but I finally figured that out.

After I resolved that, I put a 30amp fuse in place of the 10amp, and put the LEDs back in. It looks nice, but what a pain in the a$$! So now I have nice looking dash lights, but created a turn signal problem.

I still can't get that left turn signal light working. I tried replacing the bulb with one of the others, nothing. I tried swapping the entire bulb and twist lock with the one that IS working, nothing. I tried LEDs, nothing. I can't figure it out. What do you guys think it could be?
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 09:35 PM   #12
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
Quote:
Originally Posted by NHEric View Post
dimmer? It doesn't explain the blinker, but it does explain the rest.

I'm definitely no mechanic or electrician, but common sense still serves me!

Quote:
Originally Posted by Jma20a View Post
did you clean the connections on the back of the cluster before re-installing it? i had a few issues when i changed my bulbs.
Yeah, everythings clean. Got that taken care of, but can't figure out the turn signal light.
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 09:37 PM   #13
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
probably fried the circuit on the cluster. 30 amp fuse in place of a 10 is not a good idea.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 01-24-2009, 09:46 PM   #14
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
The turn signal went out before I ever started messing with fuses though.

????
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 09:59 PM   #15
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
The guys at the auto parts store said that swapping the fuses wouldn't hurt anything. Are they full of it?

I'll go try a 15 and see if it pops that one. Now that the turn signal light is gone, I'm not going back to stock Dash Lights. That would be doing it all for nothing and ending up with less.

Can anyone figure out what else the problem might be? Or do ya think that the turn signal light is gone beyond repair?
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-24-2009, 10:12 PM   #16
Jeeper
 
BLACKTOOTHGRIN's Avatar
 
Join Date: Sep 2008
Location: South Of Heaven
Posts: 1,210
Well, I just through a 10amp back in there just for sh%ts and giggles. Its now working fine with the 10amp. WTF? None of this is making any sense to me. Why would it pop 2 fuses @ 10amps and now start working?

Still no luck with the turn signal light though. I'm going to go put it all back together now, but if anyone has any suggestions, please share! It's not big deal to take it back apart, tonight, tomorrow, or even in a week.
__________________
"ONE FOOT IN THE GUTTER, ONE FIST IN THE GOLD"
-BLACKTOOTHGRIN
BLACKTOOTHGRIN is offline   Quote Quick Reply
Old 01-25-2009, 08:08 AM   #17
Jeeper
 
firefighter8816's Avatar
 
Join Date: Dec 2008
Location: Ansbach, Germany
Posts: 60
sounds like a short somewere
__________________
....._____
/l ,(_____),
l---L
()lllllll()-
()_) ()_)----)_)
firefighter8816 is offline   Quote Quick Reply
Old 01-27-2009, 12:02 AM   #18
Jeeper

WF Supporting Member
 
Kauka's Avatar
 
Join Date: Oct 2008
Location: Ridgecrest, CA
Posts: 251
I know this seems like a long shot, but check your front and rear turn signal bulbs. Maybe you shorted something and it blew a bulb.
__________________

1" motor & body lift. BDS 2" Suspension lift, BDS 5500 Series Shocks, ZJ tie rod conversion, LED Dash Lights MOD
Kauka is offline   Quote Quick Reply
Old 04-03-2009, 09:26 AM   #19
Jeeper
 
Contra's Avatar
 
Join Date: Oct 2008
Location: San Antonio, Tx
Posts: 208
Quote:
Originally Posted by BLACKTOOTHGRIN View Post
The guys at the auto parts store said that swapping the fuses wouldn't hurt anything. Are they full of it?

I'll go try a 15 and see if it pops that one. Now that the turn signal light is gone, I'm not going back to stock Dash Lights. That would be doing it all for nothing and ending up with less.

Can anyone figure out what else the problem might be? Or do ya think that the turn signal light is gone beyond repair?

the guiy at the auto parts store are minimum wage earning clerks...
not mechanics, they have no training

__________________
My Off Road Videos
Contra is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC