Need help she wont run right? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-12-2008, 09:05 PM   #1
Newb
 
Join Date: Nov 2008
Location: bradford ohio
Posts: 1
Need help she wont run right?

Hi, i have a 1999 tj 4 cyl. on some days when you start her up she wont idle next day its fine.might happen once a week or not for 2 weeks but anyway it will stall.if you give it gas or drive it away it wont miss a beat.if you push in the cluth the tach will drop to 5000 or completly die it usually runs just under 10000 i assume it has something to do with the choke or a sensor or maybe o2 sensor? i have changed plugs and wires and run fuel injector through it.Whats going on with her im about to get laid off hoping to make it to xmas so i just cant be throwing parts in her any help would be greatly appreciated Thanks Jeepman

Dale Smith is offline   Quote Quick Reply
Old 11-12-2008, 09:22 PM   #2
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 9,965
Images: 5
Welcome, I should really know the problem, but I can recall the parts or part it might be. I want to say the MAP senor but I think that is way off. Hopefully someone will chime in with the correct thing

__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote Quick Reply
Old 11-12-2008, 09:25 PM   #3
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
First guess would be throttle position sensor, you typed 5thousand and 10thousand I think you mean 500 and 1thousand. If you have a meter or digital voltmeter you can unplug the throttle position sensor on the back of the throttle body facing the firewall, stick the meter on there and set it to ohms, then operate the throttle by hand, watch the meter, it should go up and down in resistance smoothly. The other thing that effects idle is the sensor on the throttle body facing the valve cover, remove it and clean it. It's the IAC or Idle air controller, when it gets dirty and blocked it cuts off air at idle.
richp is offline   Quote Quick Reply
Old 11-13-2008, 08:33 AM   #4
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,822
Is the CEL on?
Atthehop is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:25 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC