Need help with sensors!! Pleaseee - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-13-2010, 12:15 PM   #1
Jeeper
 
Wrangler06's Avatar
 
Join Date: Jun 2010
Location: Roanoke Virginia
Posts: 1,643
Angry Need help with sensors!! Pleaseee

Im sure people have had this problem because my local jeep dealer says it is a problem with many jeep/chrystlers right now. so here goes..i have a 2006 Wrangler SE, 2.4l 4 cyl 6 speed manual and this has happened twice..at interstate speed in 6 gear (55-65 mph) with the AC on the jeep lurched forward and was hard to shift into 5th and 6th gear..but after riding it out for a minute it clears up but the check engine light is on.. the second time it happened the light went off on its own after about 20 miles or so ..had it checked at advanced auto and it says that it is the MAP and TPS sensor correlation at load...i was told that it was the sensors going out first but then was told that its just the correlation between the two and the result may just be the 6th gear interstate speed with AC...my aunt recently got a wrangler too..same year 6 speed but the 4.0L ..you know how our jeeps have the two outlets under the stereo? one has a solid black cap the other says "power outlet"..well supposedly the one that is just black is only for cigarette lightyers..and the guy at the dealership she got hers from said if you plugged any cell phone charger or anything into the cigarette lighter it would fault with the ECU..well i used a car charger in the lighter one (not knowing this untill afterwards) and the guy at advaced auto who is a friend of mine and is extremely engine/electrial smart says that doing that may have messed up the correlation.......Sorry that was soooo long BUT, in conclusion...Does anyone know a fix for this? Anyone experienced the same thing? Please Help!!! id rather not pay the jeep dealership 95 dollars to look at it..78 for a map sensor and 28 for a tps PLUS labor..Thanks for everyones help in advance!!!!!!

__________________
Impact Orange 06 Wrangler SE 2.4l 6 speed
OME and Bilsteins, 31x10.50 Kelly Safari Tsr
Magnaflow Exhaust, Rustoleum Lined Tub, Hard Top, Full Doors
Wrangler06 is offline   Quote Quick Reply
Old 08-13-2010, 12:26 PM   #2
Jeeper
 
bc40ton's Avatar
 
Join Date: Jul 2010
Location: Historic Cape May, NJ
Posts: 197
About the power ports, I can say with some certainty that the cig lighter would take more juice that any cell charger, radar detector etc. So any ideas about those messing up the ECU
in my opinion is wrong. From what you describe, the TPS I would start with. You stated that it lurches, meaning as if you stepped on or off the gas pedal?

bc40ton is offline   Quote Quick Reply
Old 08-13-2010, 12:36 PM   #3
Jeeper
 
Wrangler06's Avatar
 
Join Date: Jun 2010
Location: Roanoke Virginia
Posts: 1,643
when i let off the gas pedal it lurches forward
__________________
Impact Orange 06 Wrangler SE 2.4l 6 speed
OME and Bilsteins, 31x10.50 Kelly Safari Tsr
Magnaflow Exhaust, Rustoleum Lined Tub, Hard Top, Full Doors
Wrangler06 is offline   Quote Quick Reply
Old 08-13-2010, 12:46 PM   #4
Jeeper
 
Wrangler06's Avatar
 
Join Date: Jun 2010
Location: Roanoke Virginia
Posts: 1,643
but it only did that twice..it runs fine now
__________________
Impact Orange 06 Wrangler SE 2.4l 6 speed
OME and Bilsteins, 31x10.50 Kelly Safari Tsr
Magnaflow Exhaust, Rustoleum Lined Tub, Hard Top, Full Doors
Wrangler06 is offline   Quote Quick Reply
Reply

Tags
4cyl , electrical , engine , sensor

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
o2 sensors? tobycat1 TJ Tech Forum 1 04-20-2008 02:26 PM
Oxygen Sensors Gerald TJ Tech Forum 15 03-27-2008 08:30 PM
Resetting maintenance indicator light after changing O2 sensors? ironmonk TJ Tech Forum 7 10-16-2007 07:52 PM
sensors in engine bay jeepkid189 TJ Tech Forum 5 08-20-2007 06:54 PM
o2 sensors JCS05Rubi General Jeep Discussion 3 04-19-2007 08:38 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:45 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC