Need help with wiring...Please!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-16-2009, 11:00 PM   #1
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Need help with wiring...Please!!!

As some of you know I have swapped engines in my 97 4.0 wauto to a 99 4.0 w 5 speed.I swapped computer and wiring harness also.Well I ran into my first big snag today.I got the engine and all in,wired it all up and it is not getting any power to the guages,coil,fuel pump and so on.All the lights work,the radio,heater and everything inside works but the guages are dead and the starter will turn the engine over but no spark or fuel.The plugs plugged right into the 100way connector under the dash but I am thinking changing from 97 to 99 the 99 has the Sentry Key Immobilizer were the 97 does not.The 99 has an ASD relay were the 97 did not.Now I can hook a hot wire to the B3 circuit(fused ignition switch output st-run) were the ASD(automatic shut down relay) goes and get power to the all the guages and the fuel pump but still no fire to the coil.Can anybody help me here???????????

__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 05-17-2009, 09:34 AM   #2
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Come on someone must have done a swap were they have had to tap into the wiring harness and can lead me to what wire is dead.I am figuring it is one wire from the key switch that is not going live.It may be the 5V supply for all the sensors along with the ignition output run supplythat i know is dead or it could be the most common termanal listed in alot of the sensors switches and controls.That would be the fused ignition output signal but even then it should have two 12V supplies from the igntion a start-run supply and a acc supply.I just need to know were to start.Under dash or in fuse box or were.

__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 05-17-2009, 09:51 AM   #3
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 33,158
Images: 2
I'm thinking about your problem but in the mean time, I just wanted to let you know that '97 TJs have the ASD relay too. My very early (3/96 build date) '97 with the 4.0L has one. There is 12 volts on the input stud on the Power Distribution Center inside the engine compartment right?
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 05-17-2009, 06:56 PM   #4
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Quote:
Originally Posted by Jerry Bransford View Post
I'm thinking about your problem but in the mean time, I just wanted to let you know that '97 TJs have the ASD relay too. My very early (3/96 build date) '97 with the 4.0L has one. There is 12 volts on the input stud on the Power Distribution Center inside the engine compartment right?
Yeah I found that out today.I went over the old wiring harness,PDC and the new and checked for things that were different and found the 97 did also have the ASD but found two wires missing from the connectors that plug into the 100 way socket under the dash the 97 harness had a large red/white wire and the hole is empty in the 99 plug anyway I have gave up on that idea.I did get it running now here is what I had to do.I tested the wire at the column from the ignition and found the large black/orange wire to be hot with key on and dies in the run position now if you run a hot wire to this and start the engine once started you can disconnect the hot from this wire.Oh BTW it starts just fine with the remote start feature without this wire jumped but you have to hook a hot wire to the large black/orange wire to start with key switch.Also this was all after by passing the ASD relay.Once I by-passed the ASD I had fire to the guages,fuel pump relay and coil driver wire but not to the hot wire to the coil and a few other things.I didn't get fire to the hot wire for the coil and the other things until hooking hot to the black/orange wire at the ignition.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 05-18-2009, 09:40 AM   #5
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
So what do you think Jerry??? Am I going to have to pull the 100way connector and dash wiring from the 99 to make it work like factory or would you just leave the ASD by-pass and run a toggle switch?????
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 05-18-2009, 11:06 AM   #6
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 33,158
Images: 2
When the ASD isn't enabling, that means the ECM isn't happy with one of its input signals which is often the crankshaft position sensor or camshaft position sensor. The ASD won't be enabled until the ECM is happy with everything.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 05-18-2009, 07:19 PM   #7
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Yeah the Check engine light is on also.I do have it running with the jumper in place of the ASD Relay and the momentary switch but I am stumped on how to fix it the right way short of pulling the dash out and putting the 100 way socket and dash wiring in from the 99.I did pull the dash and all out of the 99 today but I really hate to have to pull mine apart to swap dash wiring.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 06-03-2009, 11:26 AM   #8
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
If any one does a motor swap.If at all possible I suggest staying with the same year.They changed the wires in the 100 way connector from year to year so they are not compatible.

__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard top wiring kit - Rear defroster always on JCS05Rubi TJ General Discussion Forum 5 09-16-2014 08:29 AM
5.7L PCM to YJ wiring harness, need help. cowboy724 YJ Tech Forum 10 04-20-2011 03:21 PM
Engine swap wiring help needed 4.2 to XJ 4.0 89Islander YJ Tech Forum 8 04-05-2008 09:06 PM
Hitch Wiring rcmerlin TJ Tech Forum 1 12-06-2006 10:43 AM
Replace all wiring in 2000 TJ? blueelkwrangler TJ Tech Forum 4 08-24-2006 01:35 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC