Need some HELP!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2009, 10:34 PM   #1
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
Need some HELP!!

Hey guys this is story.
I was riding with my top down and doors off today. I was just cruisin' and all of the sudden i don't see my RPM meter or my speedometer go UP!!! They both sat at 0 and I was in fourth gear. It happened a lot. I stop at a stop sign turned her off and then on, it worked, but then started to do it again. Or if I ran over a bump it hopped back into position... I don't know the solution to this problem if anyone does, please help...

I have a 98 Jeep Wrangler Sahara, 4.0L 5spd.
Thanks!

Bignuke is offline   Quote
Old 05-30-2009, 10:51 PM   #2
Jeeper
 
B86W05's Avatar
 
Join Date: Dec 2008
Location: Dayton, Ohio
Posts: 168
its the connection behind your gauge cluster

B86W05 is offline   Quote
Old 05-30-2009, 10:56 PM   #3
Jeeper
 
B86W05's Avatar
 
Join Date: Dec 2008
Location: Dayton, Ohio
Posts: 168
there are plenty of threads on this forum explaining how to fix it
B86W05 is offline   Quote
Old 05-30-2009, 11:00 PM   #4
IITYWTMWYBMAB

WF Supporting Member
::WF Administrator::
 
4Jeepn's Avatar
 
Join Date: Apr 2005
Location: Florence, KY
Posts: 10,466
Images: 5
Quote:
Originally Posted by B86W05 View Post
there are plenty of threads on this forum explaining how to fix it
Then post one up...
__________________
79.96.85.00.01.97.00.97.93.97.95.94
CJ.XJ.CJ. TJ. TJ.ZJ. TJ.TJ. ZJ.ZJ.YJ. XJ
4Jeepn is offline   Quote
Old 05-30-2009, 11:29 PM   #5
Jeeper
 
B86W05's Avatar
 
Join Date: Dec 2008
Location: Dayton, Ohio
Posts: 168
for some reason im having trouble finding one when i had the same problem with my 98 there was plenty of them, but all you have to do is remove the gauge cluster what really isnt that hard, and clean the two connecters with a electric contact cleaner and take some dielectric grease on a toothpic and rub it in the contacts and put back together fixed mine never had another problem with it. sorry for the poor right up but im tired
B86W05 is offline   Quote
Old 05-30-2009, 11:31 PM   #6
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
stevens243 is offline   Quote
Old 05-31-2009, 09:17 AM   #7
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
Thanks guys, I was wondering if you could show me a picture of where the "guage connector" is?? THanks.
Bignuke is offline   Quote
Old 05-31-2009, 12:14 PM   #8
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
Go to the below. Get your model year TJ's FSM and look it up. I don't have a full version of adobe so I can't cut and paste diagrams here, just text.

Index of /allmanuals/Jeep
stevens243 is offline   Quote
Old 06-02-2009, 05:14 PM   #9
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
So i take off the guages?? Like the speedometer and such plate off and they are behind there??
Bignuke is offline   Quote
Old 06-02-2009, 06:48 PM   #10
Jeeper
 
B86W05's Avatar
 
Join Date: Dec 2008
Location: Dayton, Ohio
Posts: 168
yes you will see them right behind the gauge cluster just remove the gauge cluster
B86W05 is offline   Quote
Old 06-02-2009, 09:47 PM   #11
Jeeper
 
Bignuke's Avatar
 
Join Date: Mar 2009
Location: Fort Mill, SC
Posts: 1,057
Ok I found them, Thanks!

Bignuke is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC