Need some help please - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-11-2011, 06:42 PM   #1
Newb
 
Join Date: Feb 2011
Posts: 5
Need some help please

I am new to WF and have a 98 jeep wrangler sport, 4.0, 5-speed. Intermittently I will go somewhere for a short time (less than 10min) and when I try to start it back up it will not start but it does crank. This does not happen all the time, only sometimes. Just recently, when it did start after one of these episodes, it died as if it ran out of gas but I had 3/4 tank, I got it started again after the second crank but got to a light nearby and died again as if it ran out of gas, then it started after about 5-10 minutes and I made it all the way home. I am thinking fuel pump, fuel pressure regulator, or CPS. Could it be something a simple as a fuel pump relay? I am a broke student trying to get out cheapest way possible. Any ideas on the cause of my problem? Thank you in advance

jyop is offline   Quote Quick Reply
Old 02-11-2011, 06:57 PM   #2
Jeeper
 
jeeptester's Avatar
 
Join Date: Aug 2010
Location: Nankipoo, Tn
Posts: 332
IMO,
1. got to autozone and either borrow or rent their fuel press gauge
2. your right check CPS and its cable plug ( i saw one once that had got over on the exhast and melted the cable )
3. KISS principle , check the battery while at autozone and cables ends

Also you could take the CPS off and maybe they can test it for you.

There is a TON of things that could cause this just check one at a time.

jeeptester is offline   Quote Quick Reply
Old 02-12-2011, 02:20 AM   #3
Newb
 
Join Date: Feb 2011
Posts: 5
Thank you, the battery is good, just cleaned it today. I am going to check CPS tomorrow, cable looks good though. I checked all the relays today and they are all good. I am pretty sure that it is the check valve in the fuel pump, but I am trying to do all the low cost stuff first. I went to release the pressure in my fuel system today and nothing came out of the test valve on the fuel rail...turned the key to the on position, pressed in the test valve, still nothing...only when I started it gas came out. Any ideas?
jyop is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:28 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC