new onset engine rattle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-06-2013, 04:15 PM   #1
Newb
 
michaelD's Avatar
 
Join Date: Jan 2013
Location: black mountain NC
Posts: 4
new onset engine rattle

I have a 2003 TJ and just did some preventative work replacing water pump, hoses, inlet tube, rad cap, thermostat, antifreeze. Came out nice, so while I was there, I decided to replace the pair of PVC valves (one metered, one open) because the valve cover seems to be getting more oily, quicker, than it used to. That finished, my heater air control selector switch wouldn't work...found the vacuum line that I had knocked off, replaced, works fine.
What I have now is a rattle, engine speed linked, at higher rpms, (very much like the sound of engine knock at lugging speeds) that seems linked to higher rpm NOT load. I first thought: another vacuum line I knocked off...but I can't find anything off, and the motor runs excellently. another note: for the first few minutes on a cold engine, no knock at all. -as it warms up, then that deathly rattle starts....not real noisy like lugging, but there. Thoughts??

michaelD is offline   Quote Quick Reply
Old 02-06-2013, 04:27 PM   #2
Jeeper
 
Gold Miner's Avatar
 
Join Date: Jan 2013
Location: way up thar
Posts: 497
worse case scenario....
bent push rod?

__________________
'01 Sahara, Original Owner
BDS, OME, Metalcloak,
JKS Disco, Rough Trail, Kargo Master,.... bla bla bla, never done
Ghost Creek Mine, Owner ... Mitchell/Yooper Placer Mine, Owner
Only thing we have to fear is, fear itself....................................... and bears
Gold Miner is offline   Quote Quick Reply
Old 02-06-2013, 04:35 PM   #3
Newb
 
michaelD's Avatar
 
Join Date: Jan 2013
Location: black mountain NC
Posts: 4
hope not! I did drive about 50 miles total with the vacuum leak going on, wondering why all the air was coming out the defroster vents
michaelD is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:05 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC