New (to me) TJ with electrical gremlin.. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-25-2013, 06:47 PM   #1
Newb
 
Join Date: Jun 2013
Posts: 7
New (to me) TJ with electrical gremlin..

I just bought a 'project' 2003 TJ. I think the steering column is causing issues.
The key is hard to turn. You need to just keep trying to turn the key until it will finally turn.(Looks like a replacement cut key).Do I try to get a whole new ignition?

Most important:
The lights are stuck on HIGH beams. The icon is permanently lit on the instrument cluster, and they stay lit (just the front lights, not tail lights) after the key has been removed.

MrBeetleman is offline   Quote Quick Reply
Old 06-25-2013, 07:10 PM   #2
Jeeper
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 1,161
You can remove the cylinder and take it to a locksmith. If you put the key in and turn it 1 click, then directly under the cylinder there is a hole in the plastic shroud, insert a screwdriver or pin punch and depress button. Cylinder will slide out.

As far as the high beams for starters it is probably the multi switch (turn sig/hi/low/beam) that is messed up. The lights will stay on after the key is off as long as the light switch is on. We could be talking a bad relay here.

JimsJeep is offline   Quote Quick Reply
Old 06-25-2013, 07:30 PM   #3
Newb
 
Join Date: Jun 2013
Posts: 7
Hey, thanks for the quick response. I'll check all of the things you suggested.
MrBeetleman is offline   Quote Quick Reply
Old 06-26-2013, 06:57 AM   #4
Jeeper
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 1,161
You might be able to swap out your relay with another just to test, will check out mine when I get home later
JimsJeep is offline   Quote Quick Reply
Old 06-29-2013, 06:28 AM   #5
Newb
 
Join Date: Jun 2013
Posts: 7
The high beam issue was related to the DRL module. I unplugged it, and all is well.. Thanks for the great suggestions.
MrBeetleman is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC