New wrangler with idle problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-24-2009, 10:06 PM
Thread Starter
  #1
Jeeper
 
scoobasteve's Avatar
 
Join Date: Dec 2009
Location: Livonia, MI
Posts: 25
scoobasteve is on a distinguished road
New wrangler with idle problem

Hello everyone. I picked up my 99 Sahara from its previous owner yesterday and it runs and drives every well with the exception of one problem.

When the jeep warms up it idles very poorly with in reverse. It runs fine in drive and neutral but when you throw it in reverse the rpms drop and the idle becomes very rough unless you give it some gas.

Any ideas what may be causing the problem? Thanks for your help!

Dan
scoobasteve is offline   Quote
Old 12-26-2009, 10:51 AM
Thread Starter
  #2
Jeeper
 
scoobasteve's Avatar
 
Join Date: Dec 2009
Location: Livonia, MI
Posts: 25
scoobasteve is on a distinguished road
Does anyone have any ideas? Thanks for all your help.

scoobasteve is offline   Quote
Old 01-17-2010, 03:03 PM   #3
Newb
 
Join Date: Jan 2010
Posts: 2
jmatson is on a distinguished road
did you find a fix to your problem?
jmatson is offline   Quote
 
Old 01-17-2010, 03:10 PM
Thread Starter
  #4
Jeeper
 
scoobasteve's Avatar
 
Join Date: Dec 2009
Location: Livonia, MI
Posts: 25
scoobasteve is on a distinguished road
I did not. It is a intermittent problem that I am just learning to deal with until I have a chance to really get into it. Any ideas?
scoobasteve is offline   Quote
Old 01-19-2010, 10:57 AM   #5
Jeeper
 
nmdriver's Avatar
 
Join Date: Aug 2009
Location: Grants, NM
Posts: 259
nmdriver is on a distinguished road
This happened to me once when the battery was very dead. I left it at a shop for the weekend and the blinker switch was out and the fog lights stayed on. The next couple days it would want to idle down until it stalled. After a few days it cleared up so I never figure'd it out other then it has to be an electrical deal.

It seems like my issue was different but just throwing it out there.

Is yours auto?
nmdriver is offline   Quote
Old 01-19-2010, 03:04 PM
Thread Starter
  #6
Jeeper
 
scoobasteve's Avatar
 
Join Date: Dec 2009
Location: Livonia, MI
Posts: 25
scoobasteve is on a distinguished road
Yeah i forgot to add that it was an auto.
scoobasteve is offline   Quote
Old 01-19-2010, 03:13 PM   #7
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 42,403
Jerry Bransford is on a distinguished road
Try thoroughly cleaning the inside of your throttle body with a can of aerosol throttle body cleaner. The IAC (idle air controller) that feeds all of the engine's air into the engine at idle when you're not stepping on the gas might be sticking and not letting enough air into the engine at idle. The IAC is bolted onto the passenger-side of the throttle body and it gets its air for the engine through the slot on top of the throttle body's butterfly valve plate that is closed at idle. Make sure some of the cleaner gets into that slot (idle air control passage inlet) as you can see in the below illustration. The engine needs to be running while you do this, simply hold the rpms up a tad while you spray into the throttle body. Complete instructions will be on the back of the can.
__________________
When you have a choice, buy American.
Jerry Bransford is offline   Quote
Old 08-05-2014, 07:03 AM   #8
Newb
 
munsin12's Avatar
 
Join Date: Aug 2014
Posts: 6
munsin12 is on a distinguished road
I have a 99 with exact same issue but mine also does it in 1st gear

munsin12 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 Wrangler, 2.5L high idle LogHomeFool YJ Tech Forum 5 10-27-2009 09:52 AM
4.2 rough idle and stalling problem truemainer150 YJ Tech Forum 9 04-12-2008 05:10 PM
1997 Wrangler TJ Engine Upgrade sss TJ General Discussion Forum 1 12-11-2007 02:05 AM
different transmission problem greasem0nkey86 YJ Tech Forum 5 03-26-2007 03:31 PM
1991 wrangler taillight problem perrypeckslip YJ Tech Forum 1 09-29-2006 08:04 PM




All times are GMT -5. The time now is 05:57 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner