No Brake Lights, Rear Turn or Tail Lights - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-19-2013, 10:16 AM   #1
Newb
 
Join Date: Oct 2012
Posts: 4
No Brake Lights, Rear Turn or Tail Lights

I just picked up a 2000 Sport. The first time I drove it at night I came to a frightening realization that I had been driving with no break lights, rear turn signals or tail lights. The center brake light does work, thankfully.

I have done some research and was looking for consensus. From what I can gather it appears that it would most likely be the Turn Signal Switch located in the steering column. I have pulled the fuses and they look ok. Any other diag I should do before replacing the switch?

Phiolmo.

Philmo418 is offline   Quote
Old 11-19-2013, 12:21 PM   #2
Supporting Member

5-Year WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 8,060
It sounds like bad grounds on your tail lights if all rear lights are out. Are there lens grills installed over the lights? The housing grounds through the body and those can prevent it. take a jumper wire from the lamp holder base to a good ground, then try it.

__________________
Dennis
Water Dog is online now   Quote
Old 11-19-2013, 01:28 PM   #3
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,648
It could be the grounds but if the backup lights are working then probably not. Check that. If they are working then, are you sure you don’t have taillights? The turn signals & brake lights (except the center one) go through the signal switch but the taillights don’t. If you lose both brake & signals/flashers to the rear then yes, the signal switch is usually the problem. If no taillights then there may be 2 different problems.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Old 11-19-2013, 04:53 PM   #4
Newb
 
Join Date: Oct 2012
Posts: 4
I will check the ground tonight.

I am not getting anything. No break,tail,turn or backup. They look to be completely dead. The middle brake light works.
Philmo418 is offline   Quote
Old 11-19-2013, 05:02 PM   #5
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,648
Then it sounds like bad grounds, as WD said they ground through the body & if you have added taillight guards they often cause them not to get good grounding.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Old 11-20-2013, 09:02 AM   #6
Newb
 
Join Date: Oct 2012
Posts: 4
So this ended up being much easier that I thought but i am left scratching my head. It appears that the PO had installed some kind of protective coverings over the rear corners of the Jeep body. To do this it required removing the lights. For some reason the lights were bolted back on but never reconnected. Snap snap and voila lights.

Philmo418 is offline   Quote
Reply

Tags
brake lights problems , tail lights , turn signal , turn signal switch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:44 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC