No Heat - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-25-2008, 08:35 PM   #1
Newb
 
Join Date: Jul 2008
Posts: 10
No Heat

2004 Wrangler Sahara, I have a heater that blows cold air. I recently had a satellite antenna installed requiring the center panel to be removed. Could something have happened to my controls? When I turn the hot/cold dial it feels loose.

lgreenjeans is offline   Quote Quick Reply
Old 07-25-2008, 08:46 PM   #2
WINNAR!!!!!!
 
MR.CLIFFORD's Avatar
 
Join Date: Oct 2005
Location: THE PROVING GROUNDS
Posts: 6,520
Why would you second guess it? Just pull the center console and check the be sure everything is plugged in correctly. Sounds to me like you have a vacuum leak caused by best buy.

MR.CLIFFORD is offline   Quote Quick Reply
Old 07-25-2008, 09:15 PM   #3
Jeeper
 
Join Date: Jun 2008
Posts: 55
Since you mentioned that a dial appears loose, I would first suspect a broken or loose connection. The second thing I would check is a thermostat that is stuck open or a plugged heater core.
__________________
68 Cadillac Fleetwood
73 New Yorker
1986 Porsche 930
1995 Ford Ranger
1999 Polaris Victory Serial #332
BretStep is offline   Quote Quick Reply
Old 07-25-2008, 10:04 PM   #4
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
Don't know about there, but it would be pretty dang hard to tell if the heater was working around here right now. 100+ degrees and everything blows hot!!!
__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Old 07-26-2008, 02:11 AM   #5
Jeeper
 
spanky's Avatar
 
Join Date: Feb 2008
Location: sl,ut
Posts: 933
Quote:
Originally Posted by Dare2BSquare View Post
100+ degrees and everything blows hot!!!
i hear ya there!
__________________
2000 TJ
Dana 44 Front 60 Rear
Stroked 4.9L
TeraFlex - LCG Max Kit, SYE, 2-Low Kit, High Steer Kit w HD Tie Rod, Dual Rate S/T Sway Bar
Warn Winch
FAB Tech Front Bumper
Poison Spider - Fenders, Roll Cage
37x12.50x17 Pro Comp Mud on 17" Pro Comp Steels

Too much more to list....
spanky is offline   Quote Quick Reply
Old 07-27-2008, 07:43 PM   #6
Newb
 
Join Date: Jul 2008
Posts: 10
Okay fellas, thanks for the responses! Took center off, nothing obvious. Everything appears to be hooked up. I checked under hood and the hoses both get hot. Any more suggestions?
lgreenjeans is offline   Quote Quick Reply
Old 07-27-2008, 07:47 PM   #7
Newb
 
Join Date: Jul 2008
Posts: 10
Where are the vacuum lines?
lgreenjeans is offline   Quote Quick Reply
Old 07-27-2008, 07:54 PM   #8
Jeeper
 
tarheel's Avatar
 
Join Date: Feb 2008
Location: Clayton, NC
Posts: 1,264
Send a message via AIM to tarheel Send a message via Skype™ to tarheel
Quote:
Originally Posted by Dare2BSquare View Post
Don't know about there, but it would be pretty dang hard to tell if the heater was working around here right now. 100+ degrees and everything blows hot!!!
I had to turn on the ac for the wife while sitting in the drivethru at a local restaurant cause the airflow from the vent was so hot
__________________
Glenn
98 Sport Red 5spd
RC 2.5 lift/Daystar 1in BL/BrownDog 1 in MM/Ford 8.8 rear/Spartan lockers/RC stabilizer/JKS quicker discos/FabFour Hardcore Bumper/SB XRC8 winch
Cragar 365 series V5's/33x12.50 Goodyear Wrangler Duratracs/Grant Tire carrier bumper/Uniden pc68ltw with red 4 ft Wilson FGT,
tarheel is offline   Quote Quick Reply
Old 07-28-2008, 08:15 PM   #9
Newb
 
Join Date: Jul 2008
Posts: 10
OK. I think I have narrowed the problem down to the blend door actuator under the passengers side. I'm going to replace it and see if that works.
lgreenjeans is offline   Quote Quick Reply
Old 08-07-2008, 10:06 AM   #10
Newb
 
Join Date: Jul 2008
Posts: 10
Fixed!

Ok, to sum it up, I narrowed it down to the blend door actuator located right of center, below left of glove box. Dealer wanted 93.00 for new one. Found one on e-bay (of course) for 25.00. Plugged it in, 3 hex-head screws, and I'm back in business. I wanted to finish this thread because so many times you get closer to finding out your "fix" and the thread starter fails to post what actually worked. Thanks for the suggestions fellas!
lgreenjeans is offline   Quote Quick Reply
Old 08-07-2008, 11:34 AM   #11
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,484


Nice job.. BTW - Welcome to WF
__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote Quick Reply
Old 08-07-2008, 01:32 PM   #12
Jeeper
 
Join Date: Aug 2007
Posts: 78
Thumbs up problem solved

Quote:
Originally Posted by lgreenjeans View Post
Ok, to sum it up, I narrowed it down to the blend door actuator located right of center, below left of glove box. Dealer wanted 93.00 for new one. Found one on e-bay (of course) for 25.00. Plugged it in, 3 hex-head screws, and I'm back in business. I wanted to finish this thread because so many times you get closer to finding out your "fix" and the thread starter fails to post what actually worked. Thanks for the suggestions fellas!
Good Job! Good job on problem solving. It feels good doesn't it? Also buying the part on Ebay also

AzTrailRunner is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
heat abecker TJ General Discussion Forum 4 01-28-2009 10:56 AM
Problem with heat orange05tj TJ Tech Forum 4 01-16-2009 01:21 PM
heat help...? nregas1 TJ Tech Forum 8 03-01-2008 01:41 AM
Wow I didn't think it put out this much heat blueroo General Jeep Discussion 6 02-23-2008 12:48 AM
Heat memsimba TJ Tech Forum 5 01-15-2006 08:25 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:47 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC