No horn? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 05-02-2013, 08:43 PM   #1
domonicplague's Avatar
Join Date: Dec 2012
Location: tillsonburg, on
Posts: 306
No horn?

Ok so i took my dash apart a couple weeks ago to replace the metal frame and when i put it back together i noticed that i had no horn. I dunno exactly when it stopped working cause i went mudding the weekend befor and went in some deep water iv test both the horns and one is bad and the others fine do both horns have to be working? iv tested the wires and it dont seem to get any current but iv checked all the fuses and there fine. And i took the dash apart again to paint it but the only wires i found unplugged didnt have anything to plug in to. So any suggestions?

domonicplague is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:19 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC