no idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-19-2013, 04:16 PM   #1
Newb
 
vincent13's Avatar
 
Join Date: Mar 2012
Posts: 5
no idle

My timing belt broke. I replaced it. Got it back in time. It runs down the road fine.but when you slow down to idle it dies. Same when u start it u need to keep rpms up. Was told by a parts store that the crank position senor is bad. What else could be the problem? Thanks for any help.

vincent13 is offline   Quote
Old 01-19-2013, 04:24 PM   #2
Abe Froman

5-Year WF Supporting Member
WF Supporting Member
 
doclouie's Avatar
 
Join Date: Feb 2010
Location: Was in the mountains, now in Texas
Posts: 3,709
Images: 4
Could be off a tooth. Either on the distributor or the timing chain.
__________________
2000 Sahara, 3.5" Rubicon Express Lift, 1" spring spacer & 1" Body Lift, 33" or 35" BFG Mud tires, Front & Rear ARB, Rancho 9000 shocks, UCF Ultra High Belly Up

doclouie is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:38 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC