No power - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-25-2012, 08:10 PM   #1
Jeeper
 
97GreenGiant's Avatar
 
Join Date: May 2012
Location: Woodruff
Posts: 191
No power

About a week ago I hit a deer. Well actually the deer hit me it ran into the side of my jeep and then went up under it and got ran over. I immediately stopped and made sure nothing broke. But then when I started driving I heard a loud pop. Looked again cant find anything. Then about a mile from the house the gas pedal made a little pop (felt it more than I heard it) now the pedal is real easy to push in and it's like the jeep doesn't have the power it used to?? Any ideas where to look? Can I tighten the pedal??
Btw 97 2.5l on 35's 4inch lift idk if any matters

97GreenGiant is offline   Quote
Old 10-25-2012, 08:14 PM   #2
Jeeper
 
Join Date: Oct 2012
Posts: 18
you might have popped the throttle cable off of one of the bushings that add tension. go to the throttle body and make sure it is wrapped around all the bushings and follow it all the way back to the pedal

warrenc is offline   Quote
Old 10-26-2012, 05:24 PM   #3
Jeeper
 
97GreenGiant's Avatar
 
Join Date: May 2012
Location: Woodruff
Posts: 191
Tried that and it is all connected I looked at the top of the pedal and there is alot of extra cable that can me pulled through any tensioners on the throttle cable?
97GreenGiant is offline   Quote
Old 10-26-2012, 05:58 PM   #4
_____O|||||||O_____

WF Supporting Member
 
MVintherTJ's Avatar
 
Join Date: May 2011
Location: Texas
Posts: 108
Quote:
Originally Posted by 97GreenGiant View Post
About a week ago I hit a deer. Well actually the deer hit me it ran into the side of my jeep and then went up under it and got ran over. I immediately stopped and made sure nothing broke. But then when I started driving I heard a loud pop. Looked again cant find anything. Then about a mile from the house the gas pedal made a little pop (felt it more than I heard it) now the pedal is real easy to push in and it's like the jeep doesn't have the power it used to?? Any ideas where to look? Can I tighten the pedal??
Btw 97 2.5l on 35's 4inch lift idk if any matters
THAT is why you have no power..
__________________
2005 Jeep Rubicon TJ
Check out my Jeep Profile for details
MVintherTJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:07 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC