Noticed what may be leakage on bell housing. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-01-2012, 12:04 PM   #1
Jeeper
 
Jgood738's Avatar
 
Join Date: May 2012
Location: Indiana
Posts: 195
Noticed what may be leakage on bell housing.

While changing oil we noticed this. What do you guys think? Freaking out a bit.


Thanks

__________________
The female body is a work of art. The male body is utilitarian. It's for gettin' around. It's like a Jeep. --ELAINE BENES, Seinfeld
Jgood738 is offline   Quote Quick Reply
Old 12-01-2012, 12:12 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,364
Images: 2
Clean that bell housing off with brake cleaner and shop towel & see what happens after you stop the drip at the oil pan drain plug. That old oil on the bell housing looks like it could have just flown off the oil pan drain plug which is obviously dripping. Did you not notice your oil pan's drain plug is dripping?

__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 12-01-2012, 12:15 PM   #3
Jeeper
 
Jiffydarren's Avatar
 
Join Date: Feb 2009
Posts: 530
Send a message via AIM to Jiffydarren
Had a similar problem. Thought my rear main was bad and leaking. Upon further inspection I saw leakage on the top of the bellhousing at the back of the engine. Then, I thought it was the valve cover gasket. Anyway, I go to loosen up the bolts to the valve cover to find out they are finger loose. Torqued the valve cover back down (carefully because those bolts snap easy) and the leak stopped.

Start there.
__________________
Losing hours at work? Taxes up on your paycheck? Having trouble finding a doctor? Your kids trashy?

You voted for it... Stop complaining.
Jiffydarren is offline   Quote Quick Reply
Old 12-02-2012, 01:25 AM   #4
Jeeper
 
Join Date: Oct 2012
Posts: 68
I have similar problem mine has oil leaking on the bell housing started after I had a new clutch out in. Took it back and they said it was my main seal that was leaking I will attempt to see if the bolts you mentioned are loose.
homiegx is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:39 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC