Odd Problem Need Help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-03-2013, 08:56 AM   #1
Newb
 
Join Date: Aug 2012
Posts: 2
Odd Problem Need Help

I have a 2003 TJ Wrangler, 6cyl, automatic transmission, 115K miles. A few weeks ago I noticed that every time I slowed down to 30-33 mph I heard and felt a clunk under my jeep. My mechanic flushed out the transmission and put on a new seal. When I left his shop I noticed the problem wasn't fixed so I went back and took him on a drive--he noticed it too. He said that it could be the tranny. Before I lay out the bucks for a rebuild, is there anything else that could cause this? The tranny works fine otherwise. No problems shifting to other gears, no sounds, nada.

Thanks in advance for any help.

Profman is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:55 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC