oil light AGAIN! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-01-2013, 11:45 PM   #1
Join Date: Apr 2009
Location: Corona, Ca
Posts: 13
oil light AGAIN!

So I installed a mechanical oil gauge to verify my oil pressure. I am on my third sending unit and want to install a resistor or something to over ride the stock unit so the warning light stops coming on. Any ideas???

97 TJ with a 4.0L

1997 TJ Sahara Stock for now 4/2009
166,000 easy miles
4" lift, 33" GY
caveling07 is offline   Quote
Old 02-01-2013, 11:56 PM   #2
Plowboy1970's Avatar
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
Take the bulb out. Mine does it once in a while. Maybe once or twice a month. I too put a mechanical gauge in. 50 psi on the gauge and the factory hits 0....... Stupid thing.
Plowboy1970 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:33 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC