Oil Pressure = 80 Bad?? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-26-2010, 02:48 PM   #1
Newb
 
Join Date: Oct 2010
Posts: 12
Oil Pressure = 80 Bad??

Is running at high oil pressure bad? What kind of damage may it cause?

My oil pressure has been reading 80psi since I changed my oil last week. Changed oil (10W-30) and Oil Filter. It is 80 as soon as I start it. After driving about 20 miles, side roads and expressway, 10mph - 65mph, it will lower to about 65psi when I slow down getting off the expressway and will go back up slightly.

I looked through the service manual and could not find anything regarding High Oil Pressure only Low. I know the pressure relief is at 75psi, obviously this is not working.

Any thoughts?

(2000 Wrangler, 4.0 Manual)

LRMark26 is offline   Quote Quick Reply
Old 12-26-2010, 02:53 PM   #2
Jeeper
 
TjTheo's Avatar
 
Join Date: Mar 2010
Location: Bloomingburg, NY
Posts: 908
How much oil did you put in it?
The oil pressure sensor is known for going bad in the wranglers but since this happened right after you changed your oil it a little too much of a coincidence.

You're supposed to put 6 quarts in the 4.0, most likely less because the oil doesn't drain all the way when you change it.

__________________
If you dont get stuck, you're not trying hard enough.

98 tj 4.0 5 speed aka "rosie"
TjTheo is offline   Quote Quick Reply
Old 12-26-2010, 03:04 PM   #3
Newb
 
Join Date: Oct 2010
Posts: 12
I put in 6 qts, watched the dip stick as I added the last qt. Checked the stick again the other day and is in the safe zone.
LRMark26 is offline   Quote Quick Reply
Old 12-26-2010, 09:53 PM   #4
Jeeper
 
Join Date: Dec 2010
Posts: 346
A couple years ago my 2001 Wrangler 4.0 engine pegged the oil pressure right after climbing a steep jeep trail to about 11,000 feet and nearly scared me to death when I noticed the gauge. I knew that extremely high oil pressure can cause engine damage and seal leaks so I wasn't sure whether to continue on or turn around and coast back down but I shut the engine off for a few minutes while we got out and stretched. When I restarted the engine after a few minutes everything was back to normal and has been ever since. Guess the relieve valve sticks for a little bit then releases. Hope it doesn't happen again.
Gorving3 is offline   Quote Quick Reply
Old 12-26-2010, 10:29 PM   #5
Jeeper
 
Join Date: Apr 2008
Location: Mississippi Gulf Coast
Posts: 339
Send a message via AIM to CapnDean
Check your pressure relief and next replace your sending unit. See what happens then.
CapnDean is offline   Quote Quick Reply
Old 12-26-2010, 10:47 PM   #6
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
I think it's the sending unit. Mine also spiked at 80 after an oil change, probably a co-incidence. Our motors aren't known for faulty relief valves, but they are notorious for faulty oil gauge readings. I still haven't changed my sending unit and it still reads 80 most of the time. I'm going to fix it soon. First try unplugging the sending unit and spray it with WD40 and shake the excess off. Sometimes that works.
__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote Quick Reply
Old 12-27-2010, 08:03 PM   #7
Jeeper
 
Join Date: Dec 2010
Posts: 346
Quote:
Originally Posted by pokey View Post
I think it's the sending unit. Mine also spiked at 80 after an oil change, probably a co-incidence. Our motors aren't known for faulty relief valves, but they are notorious for faulty oil gauge readings. I still haven't changed my sending unit and it still reads 80 most of the time. I'm going to fix it soon. First try unplugging the sending unit and spray it with WD40 and shake the excess off. Sometimes that works.
On the 4.0 engine about where would I look for the oil gauge sending unit?

Thanks for the information.
Gorving3 is offline   Quote Quick Reply
Old 12-27-2010, 08:26 PM   #8
Jeeper
 
cork1958's Avatar
 
Join Date: Nov 2008
Location: MI
Posts: 560
I saw my oil gauge go some what ballistic one time (about 65psi) just cruising down the road shortly after I left the house.

I stopped at the gas station on my way to my brothers and when I got back in it and took off, it went back to normal. Haven't seen it do that again yet. Did freak me out though!
cork1958 is offline   Quote Quick Reply
Old 12-27-2010, 08:58 PM   #9
Jeeper
 
Plowboy1970's Avatar
 
Join Date: Nov 2010
Location: Burlington WI
Posts: 1,187
I just had mine today go the other way on my 97 4.0 auto. 0 at idle and hold 40 running. Put in a new sender. Now 35-55 running. Change the sender.

Plowboy1970 is offline   Quote Quick Reply
Reply

Tags
engine , high pressure , oil , oil pressure

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'94 4.0L/I6 Funky Oil Pressure Indication??? atomicjoe23 YJ Tech Forum 9 10-07-2011 10:09 PM
Oil Pressure drop, DD need help quick! Under the Palms TJ Tech Forum 12 10-04-2010 03:56 PM
Low oil pressure at idle 97tjcse TJ Tech Forum 9 08-24-2009 10:12 PM
Really HIGH oil pressure in cold BlackJeepoftheFamily TJ General Discussion Forum 8 11-19-2008 09:26 PM
Tire Pressure scotiez General Jeep Discussion 15 04-08-2008 05:35 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC