oil pressure drop - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-17-2006, 08:32 AM   #1
Newb
 
Join Date: Oct 2006
Posts: 1
Red face oil pressure drop

Hi there, I'm new to this so bear with me. I have a 97 TJ, 2.5.
My problem is that once in a while, the oil pressure and the idle
drop, the buzzer come on and a light comes on in the dash.
Oil pressure is normally 45 psi, and the little beast runs good.
Any takers on this problem?

mark is offline   Quote Quick Reply
Old 10-17-2006, 10:06 AM   #2
Jeeper
 
04moneypit's Avatar
 
Join Date: Jan 2006
Location: Under the hood of the jeep from hell (not mine)
Posts: 529
Of course, I'm sure you checked your oil level. But, when is it occuring? Are you driving down the street, or is it at a steep incline or decline when off roading? If #2 it could be that the oil sloshes away from the pickup tube and that will account for the drop in pressure and decrease in RPM could be caused by oil flowing into cylinders and around rotating assembly during incline. Or could be caused by a faulty ECM, if RPM drops, oil pump is driven under load from engine-> your drop in oil pressure.

__________________
If there's a will, usually there's a way, but then you get to that bolt that you still can't get to with two extensions, two universal sockets, and a contorsionist midget trying to help you.

1999 XJ Four door, mostly stock for now, but I am in the process of building a custom plate bumper.
04moneypit is offline   Quote Quick Reply
Old 10-17-2006, 11:08 AM   #3
Shake 'n Bake

WF Lifetime Member
 
khenderson's Avatar
 
Join Date: Apr 2005
Location: PHX
Posts: 1,344
Send a message via ICQ to khenderson Send a message via AIM to khenderson Send a message via Yahoo to khenderson
my 4 squirrels were doing that a while back. eventually, my alternator went out on my way to AZ. hasn't happened since. not sure if that was the cause or not, but like i said, since i replaced the alt(the only thing i've changed recently), the little guys stopped slowing down like they did.
__________________
I'ma come at your like a spider monkey!


khenderson is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low oil pressure at idle 97tjcse TJ Tech Forum 9 08-24-2009 10:12 PM
Really HIGH oil pressure in cold BlackJeepoftheFamily TJ General Discussion Forum 8 11-19-2008 09:26 PM
Tire Pressure scotiez General Jeep Discussion 15 04-08-2008 05:35 PM
T-case drop removal GrnTJ TJ Tech Forum 5 10-01-2007 05:30 PM
Oil pressure drop coyote99 TJ Tech Forum 5 09-25-2007 05:58 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC