Oil pressure gauge issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-05-2013, 04:49 PM   #1
JP3
Newb
 
JP3's Avatar
 
Join Date: Jul 2013
Location: Pittsburgh
Posts: 8
Oil pressure gauge issue

Usually happens once per day my oil pressure gauge will drop to zero and check gauges light comes on but it only lasts 2 seconds and returns to normal. Thoughts?

JP3 is offline   Quote Quick Reply
Old 08-05-2013, 07:32 PM   #2
Supporting Member

WF Supporting Member
 
LMontycj2a's Avatar
 
Join Date: Jul 2012
Location: Denver Metro
Posts: 54
Sending unit going bad. Easy to replace.
I guess I should ask first, when does it happen? Going down the road, coming to a stop, only when the engine is warm?
Mine used to do it only after Hwy driving than coming to a stop. So, I replaced it. My new one only lasted 9 months. So, I'm trying to decide where I want to put a mechanical gauge.

__________________
1997 TJ Sport, 4.0 I6, 32RH A/T, 31x10.50 General Grabber AT2, SpiderTrax wheel spacers, modified front bumper
1946 Bantum trailer
1946 CJ2A
1968 C-101 (Jeepster)
LMontycj2a is offline   Quote Quick Reply
Old 08-05-2013, 07:53 PM   #3
JP3
Newb
 
JP3's Avatar
 
Join Date: Jul 2013
Location: Pittsburgh
Posts: 8
It happens when i'm stopping except for one time it happened for a split second while just normaly driving down the road. Thanks!
JP3 is offline   Quote Quick Reply
Old 08-05-2013, 08:26 PM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 32,018
Images: 2
Replace the oil pressure sender & get it from the dealer. Senders purchased from cheap parts stores like Autozone are typically poor quality, unreliable, and not worth installing. My son's oil pressure sender failed & it took buying 3 senders on a Sunday when the dealer was closed to finally get an oil pressure sender that worked properly. One of them even read backwards... high pressure at idle & the pressure dropped when the engine was revved. That's some quality right there.
__________________
Remember that having a different opinion doesn't also require one to be a jerk when expressing it.

When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 08-05-2013, 08:30 PM   #5
Jeeper
 
Kimi725's Avatar
 
Join Date: May 2012
Location: Texas
Posts: 4,554
I had this problem, granted it wasn't in my jeep, but...what my problem was, was I had a slow oil leak. And ot would get loe on oil and the light would come on when coming to a stop. Then it would go away when I did stop or I took off again.

So if there's no oil leak and the oil level is good then look ↑ or ↓ for better answers.

Good luck
__________________
You. Yes, you there.. OFF.
Kimi725 is online now   Quote Quick Reply
Old 08-05-2013, 09:29 PM   #6
JP3
Newb
 
JP3's Avatar
 
Join Date: Jul 2013
Location: Pittsburgh
Posts: 8
No oil leaking i'm just going to replace the sender. Thanks guys!
JP3 is offline   Quote Quick Reply
Old 08-06-2013, 08:25 AM   #7
Jeeper
 
NC Bear's Avatar
 
Join Date: Jun 2012
Location: North Carolina
Posts: 1,310
I bought a sender from the dealership last Sept. and it worked perfectly until 2 weeks ago and it started acting up again. The ones from the parts box stores lasted only a couple days though.
__________________
97 Jeep TJ, the only hole she can't climb out of is DEBT.




NC Bear is offline   Quote Quick Reply
Old 08-06-2013, 09:25 AM   #8
Jeeper
 
UFOtestpilot's Avatar
 
Join Date: Nov 2012
Location: Portland, Oregon
Posts: 1,822
I got a sender from the dealership that lasted 3 days and then went bonkers. They replaced it and all has been well for about a month so far. Bound to have a bad one now and then I guess. FWIW: the factory units are made in Mexico.

__________________
For some, it is easier to kill the light inside of themselves than it is to fight the darkness all around them.
UFOtestpilot is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 08:32 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC