Oil pressure sender, replaced, I think.... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2008, 05:06 PM   #1
Newb
 
Join Date: Mar 2008
Posts: 6
Oil pressure sender, replaced, I think....

This may sound like a stupid question, but I was searching the forums for a solution to my fiance's 2000 Wrangler Sport problem. Little to no oil pressure at idle when warm. I replaced, or so I think, the oil pressure sending unit. I read something that is making me thing I replaced the wrong sensor. Which one specifically is the oil pressure sending unit?

The thing I replaced was some sort of a sensor BEHIND the oil filter, more towards the firewall, that threaded directly into the block. Is this the pressure sending unit? I have heard others refer to it as being above the oil filter, which this definitly was not. Sorry for the long post, but I hope I replaced the wrong thing and this is will be easier than I thought. Any help is appreciated. A picture might help also if anyone has one.

Black02M3 is offline   Quote Quick Reply
Old 03-18-2008, 05:58 PM   #2
Jeeper
 
parrot head's Avatar
 
Join Date: Jul 2007
Location: Connecticut
Posts: 406
The oil pressure sender is just on top of the oil filter housing and points toward the firewall. You can see it easily if you look at the oil filter from above. It doesn't thread directly into the block, it threads into the oil filter housing.

__________________
“He who knows not and knows not that he knows not, he is a fool, shun him.
He who knows not and knows he knows not, he is simple, teach him.
He who knows and knows not he knows, he is asleep, wake him.
But he who knows, and knows he knows, he is wise, follow him.”


89 yj 4 banger 5sp. 2" BL 31x10.50 fixed up and sold
97 tj 4.0 Auto 4"RC lift 33x12.50 mud rovers on outlaw IIs . Smitty bumpers
parrot head is offline   Quote Quick Reply
Old 03-18-2008, 06:00 PM   #3
Jeeper
 
parrot head's Avatar
 
Join Date: Jul 2007
Location: Connecticut
Posts: 406
Since it is a sport I assume it is a 4.0?
__________________
“He who knows not and knows not that he knows not, he is a fool, shun him.
He who knows not and knows he knows not, he is simple, teach him.
He who knows and knows not he knows, he is asleep, wake him.
But he who knows, and knows he knows, he is wise, follow him.”


89 yj 4 banger 5sp. 2" BL 31x10.50 fixed up and sold
97 tj 4.0 Auto 4"RC lift 33x12.50 mud rovers on outlaw IIs . Smitty bumpers
parrot head is offline   Quote Quick Reply
Old 03-18-2008, 06:03 PM   #4
Newb
 
Join Date: Mar 2008
Posts: 6
Quote:
Originally Posted by parrot head View Post
Since it is a sport I assume it is a 4.0?
Yes, it is a 4.0ltr. 6 Cyl.

So, are there problems with both the oil pressure sending unit, which I replaced, behind the filter, AND the oil pressure sender? above the filter?

Thanks for the replys.
Black02M3 is offline   Quote Quick Reply
Old 03-18-2008, 06:04 PM   #5
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Call it what you want, but I think you are referring to the same thing. Sending unit or pressure sender...
AzTJ is offline   Quote Quick Reply
Old 03-18-2008, 06:09 PM   #6
Newb
 
Join Date: Mar 2008
Posts: 6
Quote:
Originally Posted by AzTJ View Post
Call it what you want, but I think you are referring to the same thing. Sending unit or pressure sender...

Alright, I needed a 1 1/16' deep socket to remove it, pressure sender, that is. The reason I am questioning weather I replaced the right thing or not is:

1. because of the placement of it. behind filter vs. above filter

2. because others reffered to the part as being removed with a torx head screw driver, two screws.
Black02M3 is offline   Quote Quick Reply
Old 03-18-2008, 06:43 PM   #7
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Did it look like this?


And did it have a 2-wire lead attached to it?

If yes, then that was it.

Oil Pressure Sending Unit, Oil Pressure Switch, Oil Sending Unit, Oil Pressure deely-bob
AzTJ is offline   Quote Quick Reply
Old 03-18-2008, 06:47 PM   #8
Wrecktrician
 
4point's Avatar
 
Join Date: Dec 2006
Location: Central Sierra
Posts: 7,351
You just had to drag bob into this................didn't you.
__________________
Just getting to work is an adventure.
4point is offline   Quote Quick Reply
Old 03-18-2008, 07:16 PM   #9
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Quote:
Originally Posted by 4point View Post
You just had to drag bob into this................didn't you.
No bob... deely-bob.
AzTJ is offline   Quote Quick Reply
Old 03-18-2008, 08:34 PM   #10
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
What brand filter is on there ? If it's a fram change it to a Mobil-1, K&N, purolator, hastings, NAPA gold, anything but a fram or a fram rebadged.
richp is offline   Quote Quick Reply
Old 03-18-2008, 11:39 PM   #11
Newb
 
Join Date: Mar 2008
Posts: 6
Quote:
Originally Posted by richp View Post
What brand filter is on there ? If it's a fram change it to a Mobil-1, K&N, purolator, hastings, NAPA gold, anything but a fram or a fram rebadged.
It actually is a Fram Tough guard or something oil filter. Tomorrow I am going to replace the sender, again and change the filter. I'll let you know what happens. Thanks for the help.
Black02M3 is offline   Quote Quick Reply
Old 03-19-2008, 06:16 AM   #12
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
Quote:
Originally Posted by Black02M3 View Post
It actually is a Fram Tough guard or something oil filter. Tomorrow I am going to replace the sender, again and change the filter. I'll let you know what happens. Thanks for the help.
One other thing, on my 97 I have a funky connector or wire, sometimes it drops to -0- and if I get out and touch the connector it goes back up again. Might want to try that.
richp is offline   Quote Quick Reply
Old 03-19-2008, 07:58 AM   #13
Jeeper
 
parrot head's Avatar
 
Join Date: Jul 2007
Location: Connecticut
Posts: 406
Quote:
Originally Posted by AzTJ View Post
Call it what you want, but I think you are referring to the same thing. Sending unit or pressure sender...
Yup

__________________
“He who knows not and knows not that he knows not, he is a fool, shun him.
He who knows not and knows he knows not, he is simple, teach him.
He who knows and knows not he knows, he is asleep, wake him.
But he who knows, and knows he knows, he is wise, follow him.”


89 yj 4 banger 5sp. 2" BL 31x10.50 fixed up and sold
97 tj 4.0 Auto 4"RC lift 33x12.50 mud rovers on outlaw IIs . Smitty bumpers
parrot head is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low oil pressure at idle 97tjcse TJ Tech Forum 9 08-24-2009 10:12 PM
oil pressure sender speepdaedeesi TJ General Discussion Forum 11 01-19-2009 07:38 PM
Really HIGH oil pressure in cold BlackJeepoftheFamily TJ General Discussion Forum 8 11-19-2008 09:26 PM
Where to find my Oil Pressure Sender TJ jeepski TJ Tech Forum 4 12-06-2007 08:40 PM
high oil pressure! HELP!!! matty0335 TJ Tech Forum 7 10-20-2006 04:03 PM



» Featured Product

All times are GMT -5. The time now is 10:48 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC