Oil pressure sending unit? am i screwed? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-14-2010, 02:25 PM   #1
Jeeper
 
AtcoTrailsINC's Avatar
 
Join Date: Feb 2010
Location: Camden County NJ
Posts: 442
Send a message via AIM to AtcoTrailsINC
Oil pressure sending unit? am i screwed?

well ive owned my wrangler for about2 weeks now. She's got 112,400 miles on her. Noticed shes got a little valve noise which i can only describe as sounding like a quiet diesel but ive heard this noise is somewhat normal for the 4.0 Well, today i went to home depot and the drive there was fine nothing unusual until i came out and started her up. No oil pressure and the check gauges light was on. This happened once before but about 20 seconds after i started it it went back up. Normally i see about 40 to 50 psi on a cold start and after it warms up i see anywhere from 20 at idle to 50 at freeway speeds. Do you think this is a failed/failing pressure sending unit? or am i screw? Where is the pressure sending unit? i hear they aren't too difficult to replace and are fairly cheap. Sure hope this is covered under my 3 month unlimited mile power-train warranty.

AtcoTrailsINC is offline   Quote Quick Reply
Old 03-14-2010, 02:29 PM   #2
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,823
I would replace the sending unit, they are cheap. Mine went to zero one morning going out of the driveway and that's all it was. It's very common.

__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is online now   Quote Quick Reply
Old 03-14-2010, 02:35 PM   #3
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,484
If you lost oil pressure (e.g. pump or bearing failure), you would not make it very far and the noise it would make would be unmistakeable. The 4.0L valvetrain makes some chattering noise and this is normal.

Double check the wiring to the sensor. If it's ok, then get yourself a new sensor.
__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote Quick Reply
Old 03-14-2010, 02:35 PM   #4
Jeeper
 
bjtoth's Avatar
 
Join Date: Mar 2010
Location: Lafayette IN
Posts: 87
I had issues of it dropping off at random times and it did turn out to be the sending unit. As I remember, it was about 10 bucks, and took 2 minutes to replace. It's on the passenger side and I think its just above the oil filter mounted horizontally.
bjtoth is offline   Quote Quick Reply
Old 03-14-2010, 02:38 PM   #5
Jeeper
 
AtcoTrailsINC's Avatar
 
Join Date: Feb 2010
Location: Camden County NJ
Posts: 442
Send a message via AIM to AtcoTrailsINC
thanks everyone im going to just replace the sending unit myself and hope for the best just kinda scary when you havn't even made the first payment on a new car and the oil pressure drops completely.
AtcoTrailsINC is offline   Quote Quick Reply
Old 03-14-2010, 02:46 PM   #6
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,484
Quote:
Originally Posted by AtcoTrailsINC View Post
thanks everyone im going to just replace the sending unit myself and hope for the best just kinda scary when you havn't even made the first payment on a new car and the oil pressure drops completely.
Ah... it just adds to the excitement.

Go fix it and enjoy it now. Take the extra cash you would have spent on a repair center and buy a Haynes or Chilton's repair manual at NAPA. Keep it next to the crapper and inspire yourself every time yuo make a deposit.... I like to call it muti-tasking.
__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote Quick Reply
Old 03-14-2010, 03:07 PM   #7
Jeeper
 
AtcoTrailsINC's Avatar
 
Join Date: Feb 2010
Location: Camden County NJ
Posts: 442
Send a message via AIM to AtcoTrailsINC
Quote:
Originally Posted by MOz View Post
Ah... it just adds to the excitement.

Go fix it and enjoy it now. Take the extra cash you would have spent on a repair center and buy a Haynes or Chilton's repair manual at NAPA. Keep it next to the crapper and inspire yourself every time yuo make a deposit.... I like to call it muti-tasking.
Words of wisdom hopefully shes all fixed by later this afternoon and i can go take her on some runs, perfect day for some good mud
AtcoTrailsINC is offline   Quote Quick Reply
Old 03-14-2010, 04:10 PM   #8
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
Better to get a real factory service manual rather than those cartoon books. Those often show a different year than you have, or are just plain wrong. Too generic!

You can get the right FSM from the dealer, or there are lots of book sellers that have them - do a internet search, or on E=bay. You can even get it on CD for about $25.
__________________
It's no wonder the country is falling apart - stupidity abounds!
rrich is offline   Quote Quick Reply
Old 03-14-2010, 04:15 PM   #9
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,484
Quote:
Originally Posted by rrich View Post
Better to get a real factory service manual rather than those cartoon books. Those often show a different year than you have, or are just plain wrong. Too generic!

You can get the right FSM from the dealer, or there are lots of book sellers that have them - do a internet search, or on E=bay. You can even get it on CD for about $25.

I say start small and work your way into it. The Chilton's manuals provide a high level introduction to repairs. When you move up the ladder and start taking apart the motor or trans...then step up to a shop manual. For $12...it's a no brainer and it will provide 95% of what most people need.
__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote Quick Reply
Old 03-14-2010, 09:43 PM   #10
Jeeper
 
AtcoTrailsINC's Avatar
 
Join Date: Feb 2010
Location: Camden County NJ
Posts: 442
Send a message via AIM to AtcoTrailsINC
Thanks guys im going to pick up a manual and a shop manual asap. Does anyone know of any good write-ups on replacing the oil pressure sending unit? Ive done a lot of major repairs on cars but things that seem this simple always seem to have a catch to them. Don't wanna go just taking it off and ending up with crap all over the place, only crap on my jeep is mud and scratches

oh btw, went out tonight (oil pressure gauge still read 0 all the time) when i came back out to go home, what do ya know the oil pressure rose after starting just as it should .... go figure no matter what though the sensors being replaced as a piece of mind.
AtcoTrailsINC is offline   Quote Quick Reply
Old 03-14-2010, 10:01 PM   #11
Jeeper
 
dpc46's Avatar
 
Join Date: Mar 2010
Location: 15 miles north of seattle
Posts: 185
Replaced mine last week. It's actually amazingly easy.

The sending unit is mounted on the housing of th oil filter. There is a small saftey clip holding the wiring on, remove that and the plug will come undone. Take a wrench and loosen the sending unit (mine was hand tight). When you go to the store to get a new one bring your old one to make sure you get the correct one. I ended up having to buy one from a Cherokee because of a screw up at the factory.

Go home and screw it on and plug the wiring and saftey clip back in and your good to go.
__________________
1998 TJ Sport
5spd 4.0L
2.5"Rancho Lift
33x12.5R17 Baja Claw
17x8 Mach Beadlocks

www.CORE4x4.com
dpc46 is offline   Quote Quick Reply
Old 03-15-2010, 04:54 AM   #12
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,823
Quote:
Originally Posted by AtcoTrailsINC View Post
Thanks guys im going to pick up a manual and a shop manual asap. Does anyone know of any good write-ups on replacing the oil pressure sending unit? Ive done a lot of major repairs on cars but things that seem this simple always seem to have a catch to them. Don't wanna go just taking it off and ending up with crap all over the place, only crap on my jeep is mud and scratches

oh btw, went out tonight (oil pressure gauge still read 0 all the time) when i came back out to go home, what do ya know the oil pressure rose after starting just as it should .... go figure no matter what though the sensors being replaced as a piece of mind.
If you want the FSM as a PDF PM me withyour year.

__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sending Unit jeep95 TJ General Discussion Forum 8 05-24-2011 09:10 AM
Which oil pressure sending unit bspeckchaser TJ Tech Forum 1 06-26-2009 08:37 PM
87 yj 2.5 fuel sending unit options In2b8u YJ Tech Forum 1 05-12-2009 08:12 PM
new head gasket and sending unit..still have oil pressure gauge issue TXST8tj TJ General Discussion Forum 10 09-18-2008 11:37 AM
wtb sending unit and or fuel pump scooter18155 Classifieds Archive 4 01-03-2007 04:20 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:56 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC