oil pressure sensor/sender/switch - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-18-2009, 08:36 AM   #1
Jeeper
 
Join Date: Oct 2008
Location: Fort Drum, NY
Posts: 388
oil pressure sensor/sender/switch

mine is out i think. lost oil pressure while idling. when i first turn on the jeep, it takes a second for the oil pressure to go up, but then it slowly goes back down, and the check guages light comes on. it does rise with idle, which ive heard means the pump is still working, its just the switch gone bad.

anyone agree?





call it what you will, sender, switch, sensor= but just to put this out for those in the future that need to find one...

online the cheapest i can find one is a little over 30 bucks shipped.

autozone= 35 - 10% military discount

advanced= 25 - 10% military discount


so go to advanced, or at least call the parts places around you before you assume online is cheaper.

thats 5 more dollars gas i can put into my snowblower lol

__________________
97 TJ, 4cyl, auto, bone stock, 86k miles.
speepdaedeesi is offline   Quote Quick Reply
Old 01-18-2009, 11:40 AM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,485
Images: 2
I agree with you, it sounds like nothing more than a bad oil pressure sender. My '97 TJ is on its second sender, I think early TJs came with senders that tended to go bad as this is a very common issue.

__________________
Remember that having a different opinion doesn't also require one to be a jerk when expressing it.

When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 01-30-2009, 08:42 PM   #3
Newb
 
Join Date: Jan 2009
Location: Inland Empire
Posts: 12
mine still bad after I replace with 'new' sender from autozone...I might get a new bad sender....I will return it tomorrow..
waterhydrant is offline   Quote Quick Reply
Old 01-31-2009, 09:12 AM   #4
Jeeper
 
Hase's Avatar
 
Join Date: Jul 2007
Location: Berkley
Posts: 16
Oil Pressure Sensor

I got a 97 about 6 months ago. When I got it, mine did the exact same thing. Spend $3 for a can of electrical contact cleaner.

I cleaned it out as soon as I got it home and it worked for like a week. Cleaned it a second time really well and have not had the problem since. Make sure after cleaning that you get it plugged in all the way. Mine liked to make partial contact because of the o-rings.
Hase is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low oil pressure at idle 97tjcse TJ Tech Forum 9 08-24-2009 10:12 PM
Really HIGH oil pressure in cold BlackJeepoftheFamily TJ General Discussion Forum 8 11-19-2008 09:26 PM
Tire Pressure scotiez General Jeep Discussion 15 04-08-2008 05:35 PM
High oil pressure question Demodave TJ Tech Forum 3 06-01-2007 09:57 AM
high oil pressure! HELP!!! matty0335 TJ Tech Forum 7 10-20-2006 04:03 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC