onboard computer or o2 sensor? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-05-2009, 07:15 PM   #1
Newb
 
Join Date: Dec 2009
Location: Maryland
Posts: 5
onboard computer or o2 sensor?

I have an 06 wrangler x and was wondering if anyone else has experienced this problem. A couple of months ago I received a check engine light and it was an o2 sensor code. So the sensor was replaced but then the light returned reading the same sensor. The voltage off the computer was tested and it turned out that the voltage for the sensor was fluctuating which was causing the flag. I was told to wait a day till the light came back on and take it back to the dealer because the computer was under an 80000 mile warranty. The light never came back on until about 4 months later. I just changed oil and my coolant was a little low right before so I thought they may have caused something. I topped my coolant, checked my oil, pulled the negative battery terminal and reset the computer. The light never came back on..until now, about another 3 to 4 months. Again I reset the computer the other day and it has yet to come on. My thought is that there is a blown capacitor somewhere on the computer which means they can replace it if it is under warranty. A couple other people told me it could be a faulty ground somewhere. If I take it to the dealer they will charge me $100 in diagnostics to tell me its an o2 sensor and will try to replace it. I will tell them no its not, but we all know the dealer does what they want. Any suggestions or has anyone experienced this problem? thanks

cjandthetj is offline   Quote Quick Reply
Old 12-20-2009, 06:52 AM   #2
Newb
 
Join Date: Dec 2009
Posts: 2
Shop around and buy a cheap code reader you can buy one from Mac Tools it cost $70. It only reads engine codes not SRS,ABS or gives any Data. But will point you in the right direction if you do not want to pay your mechanic to scan your engine light clear it and send you on your way. Just google your code and research, you will be amazed what info you will find. As for the o2 sensor this is quite common for it to be lazy and not cycle enough or at all in closed loop which could take days, weeks or even months depending on the severity of the sensor. The only problems that I have had with o2 sensors that the engine light comes back right away after clearing the light are usually ones that have an open circuit in the wiring or the heater circuit in the sensor is cooked. So you may want to diagnose a little further, good luck.

zeke8 is offline   Quote Quick Reply
Old 12-20-2009, 07:36 AM   #3
I am JD & It's my Dream

WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 26,992
Images: 4
My 06 has been doing that for about 2 years. The code shows, slow response on o2 sensor, bank 1. The light stays on for about 4-5 start ups and then goes out and stays out for a while (weeks to months), then comes back on. I never have this problem in the warm months, only in winter. It has never had any effect on the way my Jeep runs. I have tried to get it to the dealer as it is under warranty, but the light never stays on long enough to get there. Hopefully I'll be passing the stealership one day and the light will come on.
__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is online now   Quote Quick Reply
Old 12-20-2009, 10:55 AM   #4
Jeeper
 
chiro2736's Avatar
 
Join Date: Apr 2008
Location: Connecticut
Posts: 329
Quote:
Originally Posted by JDsDream View Post
My 06 has been doing that for about 2 years. The code shows, slow response on o2 sensor, bank 1. The light stays on for about 4-5 start ups and then goes out and stays out for a while (weeks to months), then comes back on. I never have this problem in the warm months, only in winter. It has never had any effect on the way my Jeep runs. I have tried to get it to the dealer as it is under warranty, but the light never stays on long enough to get there. Hopefully I'll be passing the stealership one day and the light will come on.
Exact same problem here but mine is bank 2 sensor 1. Check engine light only comes on during the winter, sometimes it is on sometimes not.
Have ignored it for over a year. No real change in fuel consumption either.
chiro2736 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
sensors/emissions and what it all does 4.0l sahara TJ Tech Forum 2 10-01-2009 03:50 AM
(bank 1 sensor 2) 02 sensor Giancarlo TJ General Discussion Forum 0 02-16-2009 06:38 PM
97 TJ O2 sensor problem HarryJeeper61 TJ Tech Forum 2 11-30-2007 05:29 AM
Oxygen Sensor OBD Code - How to fix?? AggieChris TJ Tech Forum 15 06-14-2006 11:05 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:11 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC