Oops!! Another wheel wobble... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-29-2013, 09:06 PM   #1
Jeeper
 
MadMike84's Avatar
 
Join Date: Nov 2012
Location: Wv
Posts: 163
Oops!! Another wheel wobble...

So I hit a speed bump the other day going pretty fast... I know. I'm a dummy. Anyway now both front wheels wobble when turning and it seems as if I have to turn the steering wheel a lot farther than before to turn. No clinking or clanging in the steering box or underneath. I don't see anything bent . I will be checking ball joints and hub assembly tomorrow after work.

Just wanted to see if anyone's had this problem before and found out what it was. I'll post back with what I find tomorrow.

MadMike84 is offline   Quote Quick Reply
Old 04-30-2013, 10:09 AM   #2
Jeeper
 
MadMike84's Avatar
 
Join Date: Nov 2012
Location: Wv
Posts: 163
Not ball joints... Ughh I hate suspension... Hope I can figure this out

MadMike84 is offline   Quote Quick Reply
Old 04-30-2013, 10:47 AM   #3
Jeeper
 
mrk130's Avatar
 
Join Date: Jan 2013
Location: Little Ferry NJ
Posts: 90
What do you mean by both wheels wobble??
mrk130 is offline   Quote Quick Reply
Old 04-30-2013, 01:45 PM   #4
Jeeper
 
MadMike84's Avatar
 
Join Date: Nov 2012
Location: Wv
Posts: 163
Quote:
Originally Posted by mrk130 View Post
What do you mean by both wheels wobble??
Assuming my front right passenger side tires wobbling but I shouldn't assume I know for sure my driver side front tire is wobbling when I turn.. I just noticed when I turn my wheel when stopped its twisting my frame or something. The left side of my jeep raises up. I have 31 10.50 tires is that normal or is something bent and I can't see it...
MadMike84 is offline   Quote Quick Reply
Old 04-30-2013, 02:03 PM   #5
RPM
Jeeper
 
RPM's Avatar
 
Join Date: Oct 2010
Location: steger Il
Posts: 19
Is the steering box ripped out of the frame ??? Have someone turn the wheel and watch the box engine running
RPM is offline   Quote Quick Reply
Old 04-30-2013, 02:25 PM   #6
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 5,271
Images: 11
Check your sway bar end links.
__________________
Dennis
Water Dog is offline   Quote Quick Reply
Old 04-30-2013, 05:53 PM   #7
Jeeper
 
MadMike84's Avatar
 
Join Date: Nov 2012
Location: Wv
Posts: 163
Steering box is ok, but I do see a "dent??" In the tube of the bumper above the box. I don't know how it's tight. And sway bar link on pass side is busted...I'm taking it to the shop soon to get alignment and see what's up . Just noticed its ******* my tires up big time
MadMike84 is offline   Quote Quick Reply
Old 04-30-2013, 06:48 PM   #8
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,859
Sounds like bent tie rods.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Old 04-30-2013, 07:53 PM   #9
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 5,271
Images: 11
Quote:
Originally Posted by MadMike84 View Post
Steering box is ok, but I do see a "dent??" In the tube of the bumper above the box. I don't know how it's tight. And sway bar link on pass side is busted...I'm taking it to the shop soon to get alignment and see what's up . Just noticed its ******* my tires up big time
That must have been some kind of speed bump...!
__________________
Dennis
Water Dog is offline   Quote Quick Reply
Old 04-30-2013, 10:13 PM   #10
Jeeper
 
kyjeep's Avatar
 
Join Date: Jan 2010
Location: Central Kentucky
Posts: 93
The dent in the under side of the tube above the steering box is normal. But it does sound like you did something. Remind me not to come to your neighborhood. Those speed bumps sound like killers.
kyjeep is offline   Quote Quick Reply
Old 05-03-2013, 07:33 PM   #11
Jeeper
 
MadMike84's Avatar
 
Join Date: Nov 2012
Location: Wv
Posts: 163
It was out of alignment. Nothing bent. I don't know how but that's all it was...lesson learned...WATCH out for speed bumps haha....

MadMike84 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 02:28 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC