Overdrive and Rear defroster doesn't work - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-10-2011, 03:19 PM   #1
Jeeper
 
Join Date: Jul 2010
Location: Between Illinois and Kansas
Posts: 21
Overdrive and Rear defroster doesn't work

Like the title says they don't work.
The switches don't light up and when you push them down they bounce back up. I have switched relays under the hood, transmission control relay and the rear window defogger relay and still no light nor do they stay down. I have looked at the fuses behind the glovebox and they all seem to be ok.
I did a search and someone had similar problems but not the same either, their lights in the switch would not light and that was a fuse.
I have ran down #18 for the light in the switch which would be in the fusebox behind the glovebox and #49 a senor fuse or relay but I don't know where it would be located.
I'm kinda at a loss right now....anyone have any ideas?

__________________

If I felt any better, I'd have to be twins!
isitfridayyet is offline   Quote
Old 01-10-2011, 04:20 PM   #2
Jeeper
 
HyperBuzzin's Avatar
 
Join Date: Nov 2009
Location: Western PA
Posts: 642
Have you tried the OD switch while driving.... Seeing if it disengages while moving?
The switches don't stay down when pushed. They are momentary switches.
It's possible that just the lights are burnt out.
Now if the rear defrost isn't working... that would be easily noticable by frost not being defrosted. Have you checked the electrical connections going to the defroster grid on the window?

__________________
'04 TJ Unlimited (The Original Unlimited!!)
2.25"BB, 32" M/T's & Super Swampers for off-road
Where we're goin', we don't need no stinkin' roads!!
HyperBuzzin is offline   Quote
Old 01-10-2011, 04:25 PM   #3
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
probably just burnt bulbs.
jasonwrangler is offline   Quote
Old 01-10-2011, 04:51 PM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 34,813
Images: 2
That you say your fuses "seem" to be okay is not very reassuring. Your fuses really need to be tested with a continuity tester or an ohmmeter
There are more fuses inside the power distribution center under the hood on the passenger side fender well. I'm betting you just have a blown fuse.
__________________
When you have a choice, buy American.

Jerry Bransford is offline   Quote
Old 01-10-2011, 08:24 PM   #5
Jeeper
 
Join Date: Jul 2010
Location: Between Illinois and Kansas
Posts: 21
Quote:
Originally Posted by HyperBuzzin View Post
Have you tried the OD switch while driving.... Seeing if it disengages while moving?
The switches don't stay down when pushed. They are momentary switches.
It's possible that just the lights are burnt out.
Now if the rear defrost isn't working... that would be easily noticable by frost not being defrosted. Have you checked the electrical connections going to the defroster grid on the window?
The defrost might be the connector...it did not defrost the snow tonight...I'll check it better tomorrow.
As for the the OD switch, yes I have pressed it while driving....no difference, speed up or slow down of rpm's.
__________________

If I felt any better, I'd have to be twins!
isitfridayyet is offline   Quote
Old 01-10-2011, 08:26 PM   #6
Jeeper
 
Join Date: Jul 2010
Location: Between Illinois and Kansas
Posts: 21
Quote:
Originally Posted by Jerry Bransford View Post
That you say your fuses "seem" to be okay is not very reassuring. Your fuses really need to be tested with a continuity tester or an ohmmeter
There are more fuses inside the power distribution center under the hood on the passenger side fender well. I'm betting you just have a blown fuse.
Jerry,
I will check it out better tomorrow when I can get it in a heated garage...the temp will be 12 in the morning and drop all day....I'll see what I can find out then and let everyone know.
Thanks!
__________________

If I felt any better, I'd have to be twins!
isitfridayyet is offline   Quote
Old 01-14-2011, 07:54 AM   #7
Hardcore Jeeper
 
Peepers's Avatar
 
Join Date: Oct 2010
Location: Windsor, CT
Posts: 3,320
[QUOTE=HyperBuzzin;980023]The switches don't stay down when pushed. They are momentary switches.
[QUOTE]

x2

__________________
What have we got?
We have one heavily armed Recreational Vehicle


ΣΧ
The Power Tech 6
Peepers is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:11 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC