P0107 Check Engine Light on 98 Sahara - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-20-2012, 03:53 PM   #1
Jeeper
 
kuau's Avatar
 
Join Date: Sep 2012
Posts: 19
P0107 Check Engine Light on 98 Sahara

So I have done a bunch of searches on the PO107 MAP error code and not sure what direction to take. My local mechanic wants to just replace the MAP sensor which I told him to do. I am just worried that if that's not the problem what else to check.

In further reading, I found a post where someone was talking about bringing a Jeep from Arizona to high altitude, well that's exactly my situation.
My 98 came from Arizona and now it's in Telluride, CO elevation 9800 feet.

I don't notice any issues when driving the car though.

Steven

kuau is offline   Quote
Old 07-24-2013, 01:24 PM   #2
Jeeper
 
redredjeep's Avatar
 
Join Date: Jun 2011
Location: Montrose, Colorado
Posts: 62
Quote:
Originally Posted by kuau View Post
So I have done a bunch of searches on the PO107 MAP error code and not sure what direction to take. My local mechanic wants to just replace the MAP sensor which I told him to do. I am just worried that if that's not the problem what else to check.

In further reading, I found a post where someone was talking about bringing a Jeep from Arizona to high altitude, well that's exactly my situation.
My 98 came from Arizona and now it's in Telluride, CO elevation 9800 feet.

I don't notice any issues when driving the car though.

Steven

My 97TJ had same problem, I moved from Atl,Ga to Montrose,CO. When I wheeled offroad in hi altitude my CEL came on and it ran rich and sluggish + it pingged alot at any altitude, I had to run it on premium fuel.
I changed 3 sensors (Map,throttle position,& idle air valve)& cleaned throttle body..NO CHANGE still code p0107
I read on a forum somewhere about a similar problem and it said to go to dealer and have TSB #180800 flashed PCM (up date computer software)performed.
I had this done and it took care of my problem
Runs great, back on reg. gas no or very min. ping.
Best $150. that I have spent.
Hope this helps others. Rob

__________________
Colorado Jeepin!
redredjeep is offline   Quote
Old 07-24-2013, 03:14 PM   #3
Jeeper
 
kuau's Avatar
 
Join Date: Sep 2012
Posts: 19
Thanks for the tip,
I took my Jeep down to the Montrose dealers and they did they did the firmware upgrade, light has not come on since.
kuau is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:26 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC