P0121 fault code - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-20-2013, 04:37 PM   #1
Join Date: May 2013
Location: Jacksonville Beach, FL
Posts: 3
P0121 fault code

Replaced the TPS on 4.0 inline 6 cylinder. Disconnected the battery while swapping it out. Drove the Jeep 20 miles, all speeds. When I gave it the gas to get up to 65 mph, it started bucking and wouldn't upshift (automatic). Check engine light came on. Code P0121 which indicates TPS isn't jiving with MAP sensor. Took it back up to 65 mph again and this time no issues. Is this normal following replacement of TPS as the main computer "learns"? Do I just reset the check engine light? If so, how do you do it? Appreciate any comments.

Gdawg is offline   Quote
Old 05-20-2013, 09:21 PM   #2
Evpjr's Avatar
Join Date: May 2012
Location: Bakersfield
Posts: 459
You will need an OBD code reader to reset any codes, and for the bucking an no upshift and probably loss of power, this could be the result of possibly a bad wire or loose connection in the TPS circuit.
Evpjr is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:21 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC